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About This Manual

Manual Description

The SNMP PremNet™ 5000 Manager for Windows User's Guide describes the features
and functions of the PremNet 5000 Manager in the CMS™ 400 environment and on the
HP OpenView™ for Windows™ management platform (referred to as OpenView). Itis
designed to help you configure and manage your SNMP PremNet 5000 Manager Module.
Where no distinction is made between CMS 400 or HP Openview for Windows,
information given is applicable to both environments.

This manual consists of the following chapters:

Chapter 1 - Introduction provides an overview of SNMP PremNet 5000
network and the supported I/O modules.

Chapter 2 - Managing the SNMP PremNet 5000 Network provides detailed
information for connection, configuration, and setup of your SNMP PremNet
5000 System.

Chapter 3 - Managing Specific I/O and Link Modules provides you with
configuration, monitoring, and testing procedures on the supported SNMP
PremNet 5000 I/O modules.

Chapter 4 - Reports provides you with network and nodal reports about the
configuration of your SNMP PremNet 5000 System.

Related Documentation

For further information about PremNet 5000, refer to the following manuals:

PremNet 5000 System Installation and Configuration Manual
(# 950-1460-00) for information about how to install and configure the PremNet
5000 chassis.

PremNet 5000 I/O Module Management Manual (# 950-1461-00) for
information about the specific I/O modules associated with the PremNet 5000
chassis.

PremNet 5000 Asynchronous Transfer Mode (ATM) I/0 Module
Administrator’s Guide (950-1478-00)

PremNet 5000 SONET/SDH Link Module Administrator’s Manual (950-1483-00)

PremNet 5000 T3 Link Module Administrator’s Guide (950-1488-00)



About This Manual

e PremNet 5000 Video 1/O Modules Administrator’s Guide (950-1477-00)

If you are running this application on the HP OpenView for Windows management
platform, refer to the following manuals for additional information:

*  Racal Device Managers for HP OpenView for Windows Installation Instructions
(Part No. 13D50A-14) explains application requirements and installation
instructions in the HP OpenView environment.

*  HP OpenView for Windows User’s Guide describes the features and functions of
HP OpenView.

Suggested Reading

This manual assumes that you are familiar with the Windows user interface and have a
basic understanding of networks and Simple Network Management Protocol (SNMP). If
you need supplemental information about networks, you may find the following
publications useful:

e How Networks Work. An introductory overview of networks and general
concepts, by Derfler and Fang, Ziff-Davis, Publisher

*  The Simple Book - An Introduction to Management of TCP/IP Networks. A
description of network management including SNMP, by Marshall T. Rose,
Prentice-Hall, Publisher

*  An Introduction to Network Management. The basics of network management, by
Leinwand and Fang, Addison Wesley, Publisher

*  PC/TCP Interoperability. A description of the components in network software
and how they work together. ftp Software, Inc., Publisher

If you installed applications to run under HP OpenView, you will find descriptions of
application-specific functions in the application documentation.

Terminology and Conventions

This manual uses the following tyopgraphical conventions:
» Text displayed by the system is shown in System non-bold type: Login.
*  Characters that you must input are indicated in System boldface type:
Login System

* Special keys that are pressed on a keyboard are shown in brackets: Press [Enter].
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Chapter 1
Introduction

About Your SNMP PremNet 5000 System for Windows

The SNMP PremNet 5000 is a fiber optic backbone system configured in a ring
topology. Each ring can have up to 16 nodes. One of the nodes is dedicated as the
master node and connected to the management system through a network hub. This
allows you to configure and monitor the entire network from one central location.

Each PremNet node supports up to eight I/O interface modules. These connect the
PremNet 5000 System to LANs, mainframe computers, data communication, and audio
and video applications.

Time-division multiplexing (TDM) is used to dedicate the bandwidth needed for each
application. This enables the fiber optic backbone connected to link modules to carry
data, voice and video traffic between nodes.

The SNMP PremNet 5000 has a counter-rotating architecture that maintains system
integrity in the event of a node failure or fiber optic failure between two nodes.

The previous PremNet networks were always composed of a single logical ring. The
latest release of the product allows multiple rings to connect and have a master node that
controls the entire network.

The topology of a network can be as basic as a single standalone node, or as complex as
multiple rings with multiple nodes on each ring. The application described herein
supports all the following configurations:

¢ Single-node
¢ Single-ring , Multi-node
e Multi-ring, Multi-node

This Windows""-based application provides you with an easy-to-use graphical interface
for managing your PremNet 5000 Manager. You can quickly select any management
function using pulldown menus or toolbar buttons. Graphic displays make it easy for
you to analyze management information. If you need guidance with any procedure,
context-sensitive on-line help is always a mouse click away.

The SNMP PremNet 5000 Manager is intended to provide management capabilities to
the PremNet 5000 product. The PremNet 5000 Manager application can operate on the
following network management platforms:

e Milgo Solutions Communications Management Series (CMS) 400

o Hewlett-Packard HP OpenView for Windows
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Note: This application is designed to manage the PremNet 5000 units that support the
SNMP management protocol. To manage earlier models that do not support SNMP, use
the PremNet 5000 Manager for T7 module. See the CMS 400 PremNet 5000 Manager
User’s Guide for instructions.

Node Types

A multi-ring network is constructed by interconnecting a number of single ring SNMP
PremNet networks. The latest multi-ring feature uses the Enhanced Network
Management Module (ENMM) and multi-ring firmware. The enhanced nodes are
subdivided into the following types:

1. System Master Node
2. Interconnect Node
3. Network Nodes

System Master Node

The System Master Node (SMN) provides a central point of access for Network
Management Station (NMS) control. A network management station accessing the SMN
in a multi-ring network has a global view of the network. Through the System Master
Node, a NMS can be used for the following:

view the global network topology
build inter-ring virtual circuits
view global alarm logs

view configuration databases
access remote nodes or modules

This is accomplished by a newly implemented inter-node routing and communications
protocol. There is only one SMN in a given “connected” multi-ring network. The SMN
is always node number one in Ring 1.

Interconnect Node

1-2

The Interconnect Node (IN) is used to interconnect two single rings in a multi-ring
network. This node contains at least two link modules (one in each of the Link 1 and
Link 2 chassis locations, which are used to connect the node on both Ring 1 and Ring 2).
The interconnect node is essential to the routing of messages between all nodes in a
multi-ring network. Additionally, the IN provides the ring-to-ring timeslot mapping
function required for the creation of inter-ring virtual circuits.
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Network Nodes

All nodes which are neither the System Master Node (SMN) nor Interconnect Nodes
(IN’s) are considered to be Network Nodes. Network nodes are nodes which contain
either old NMMs or new ENMMs. In a multi-ring network, a Network Node (NN) is
connected to only one single ring.

Enhanced Network Management Module

The Enhanced Network Management Module (ENMM) enables you to configure and
manage any module in any node in the SNMP PremNet 5000 System. The ENMM
issues commands through the backplane of the SMN. Commands are then sent through
the fiber backbone to the appropriate nodes of the network.

CMS 400 for Windows

The SNMP PremNet 5000 System is managed by the CMS 400 workstation which is
attached to a network hub. The hub connects to the AUI or Thinnet port on the
Enhanced Network Management Module (ENMM) installed in the System Master Node.
This User's Guide describes how to manage your system using either the CMS 400
workstation, or the HP OpenView for Windows platform described below. For
information about how to manage PremNet 5000 from a terminal, see the PremNet 5000
System Installation and Configuration Manual.

CMS 400 allows you to manage your SNMP PremNet 5000 in various ways. You have
the ability to access, view, add, modify, delete, and test specific I/O and link modules
within your SNMP PremNet 5000 chassis.

This manual describes the various I/O and link modules that can be managed in the
SNMP PremNet 5000 Chassis. For specific information about the various modules, see
the PremNet 5000 System Installation and Configuration Manual and the PremNet 5000
1I/0 Module Management Manual.

HP OpenView

HP OpenView for Windows is a "platform" for network management programs. It
provides a standard graphic interface so that multiple network applications can share a
common display and alarm system. In addition, it provides basic network management
functions to interface with devices on the network. The functionality provided for the
CMS 400 and for HP OpenView for Windows are the same, with some differences in
database, map and alarm features.
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HP OpenView for Windows consists of:

y Maps

y Autodiscovery

y Alarms

y SNMP Manager

HP OpenView for Windows SNMP platform is a PC Windows-based, entry-level,
integrated management system. The HP OpenView for Windows systems are small,
single-user, and manage a limited number of SNMP devices. Applications from many
vendors can be integrated together on the HP platform.

CMS management applications integrated with HP OpenView for Windows is a network
management product for Microsoft Windows that provides management capabilities for
Milgo SNMP managed network devices. These capabilities of HP OpenView include a
network map showing the devices in a network, and an integrated alarm log where all
events are displayed regardless of which application discovered the condition.

HP OpenView also consists of a SNMP command stack and communication utilities.
Refer to the HP OpenView for Windows User’s Guide for detailed information.

Accessing the SNMP PremNet 5000 Manager
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Via the CMS 400

Communications Management Series (CMS) 400 kernel is the base software that runs
non-Microsoft Windows and Microsoft® Windows™ workstations. It also contains the
code needed for the hub to manage your SNMP PremNet 5000 products. The new CMS
400 for Windows application, called WPREMNET, supports PremNet 5000 SNMP
multi-ring (as well as single ring and standalone). Many PremNet management features
that currently spread across several T7 applications today are concentrated here.

Although the code for managing your SNMP PremNet 5000 products is embedded
within the CMS 400 software, it can only be accessed by installing the proper key
module which literally "turns on" access to your SNMP PremNet 5000 products.

Note: The SNMP PremNet 5000 Manager key module is a separately-purchased option
to your CMS 400 System.

When a module (key) is installed on a hub, unit types supported by that key may be
added to the database. The number of units that may be added is limited by the key.

Refer to the CMS 400 Installation Manual, Chapter 3, for instructions about installing
key modules.
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Via HP OpenView

An HP OpenView for Windows application, called Communications Management Series
for HP OpenView (CMSOQOY), supports the PremNet 5000 SNMP Manager access from
the HP OpenView environment. When HP OpenView runs, CMSOV, which was created
during installation, executes as well. CMSOV registers to receive map events. The HP
OpenView maps contain all the information necessary to draw a picture of your network.
A map is made up of one or more submaps, usually organized in a hierarchy. Submaps
allow you to create several views of your network to simplify management. Submaps
are composed of icons, or symbols. An icon may represent one of the following:

e An equipment, such as a computer, printer, or access device.

Whenever you double-click the left mouse key on the PremNet S000 symbol, control is
passed to CMSOV to take appropriate action. A popup menu appears with selectable
options available for managing the PremNet 5000 network.

Although HP OpenView for Windows is intended to be a common integration platform
for multiple vendor management applications, the rules governing unintentional
interactions between such applications are not well defined.

HP OpenView for Windows supports the PremNet 5000 product alongside existing
support for other Milgo products.

For complete information about HP OpenView features, refer to the HP OpenView for
Windows User’s Guide.

For software installation instructions, refer to the Racal Device Managers for HP
OpenView for Windows Installation Instructions.

1/0 Modules

Ethernet I/0 Module

The Ethernet I/O Module is a full-forwarding bridge (non-filtering) that allows you to
connect multiple Ethernet segments or networks. The Ethernet module provides three
types of connections to the local Ethernet segment:

e Attachment Unit Interface (AUI) (female DB15) for connection to a MAU.

* Thin Ethernet coax interface (BNC) for connection to a 10BASE2 segment.

* Media Access Unit interface (MAU) (male DB15) for connection to a bridge or
other AUI port.
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High-Performance Ethernet /O Module

The High-Performance Ethernet I/O module provides full bandwidth Ethernet remote
connectivity between Ethernet segments or networks connected to the SNMP PremNet
5000 System. With this module, you can connect remote Ethernet networks through the
SNMP PremNet 5000 fiber backbone. This gives you the same functionality as if all
connected devices were together on the same logical 10 Mbps network, even though
those devices may be separated by long distances.

e Attachment Unit Interface (AUI) (female DB15) for connection to a MAU.

* Thin Ethernet coax interface (BNC) for connection to a IOBASE2 segment.

* Media Access Unit interface (MAU) (male DB15) for connection to a bridge or
other AUI port.

* Backward compatible to the Standard Ethernet 1/O card.

» Up to four timeslots may be selected.

Token Ring 4-Mbps 1/0 Module

The Token-Ring 4-Mbps I/O Module enables you to transport Token-Ring data across
the fiber backbone. This module provides eight RJ45 ports for connecting devices and a
RI/RO interface for connecting additional standalone MAUs.

Token Ring 4/16-Mbps 1/0 Module

The Token-Ring 4/16-Mbps 1/0 Module enables you to transport Token-Ring data
across the fiber backbone. This module provides four DB9 lobe ports for connecting
devices and a RI/RO interface for connecting additional standalone MAUs.

RS-232 4-Port /O Module

The RS-232 4-Port I/0 Module has asynchronous and synchronous data communication
via four RS-232 interface ports at speeds up to 38.4 Kbps. Each port on the module is
independently configurable.

RS-422 1/0 Module

The RS-422 1/0 Module has asynchronous and synchronous data communication via
four DB25 connectors with speeds up to 2.048 Mbps. Each port on the module is
independently configurable. This module supports four different clock configurations:
external synchronization, internal synchronization, slave, and asynchronous.
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V.35 I/0 Module

The V.35 1I/0O Module has asynchronous and synchronous data communication via four
V.35 interface ports at speeds of up to 2.048 Mbps. Each port on the module is
independently configurable. This module supports the standard Winchester connections.

4-Wire Voice Card I/0 Module

The 4-Wire Voice Card I/O Module provides a bidirectional analog interface suitable for
transporting up to eight voice or voice band-data (300 to 3400 Hz) circuits to another
interface module located within a SNMP PremNet 5000 network.

Video I/0 Module

The SNMP PremNet 5000 Video I/O Modules enable you to communicate video/audio
information from a central site to groups of users at remote sites. In addition,
teleconferencing offers the advantages of transmitting documents, charts, pictures, and
other visuals that can be sent over a standard television monitor.

T1/E1 1/0 Module

"T1" and "E1" are used to differentiate between the North American (T1) and European
(E1) hierarchical voice/data transmission systems used in the digital telephone network.
There are six similar I/O modules that differ only in the number of ports, data rate, and
physical interface. These I/O modules provide an interface and transport data to a
similar module in another SNMP PremNet node. They also provide transparent
transmission through the network.

3270 8/32-Port I/0 Module

The 3270 8/32-Port I/O Module allows you to connect 3270 devices to the SNMP
PremNet 5000 System. The 3270 interface consists of 32 discreet ports, although it can
be multiplexed into four 8-port groups, as in 3299 applications. It provides direct
transport of up to 8, 16, or 32 ports of non-multiplexed data to and from the controller
and peripheral devices. It also provides transport of four ports of pre-multiplexed data to
and from a Terminal Multiplex Adapter (TMA) to a remote node where either a TMA is
resident or a 32-port interface module is present in the SNMP PremNet 5000 System.
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5250 8-Port and 4-Port I/ O Modules

The 5250 I/0 Modules transport the 5250 serial bit stream across the fiber backbone
using one TDM timeslot. The module is available in either an 8-port RJ-45 type
interface or a 4-port Twinax type interface for workstation/controller connectivity. You
can connect these modules in a multi-module configuration, such as one controller
module with multiple peripheral or multiplexer modules. You can configure the port
connection at the module level.

Asynchronous Transfer Mode (ATM) I/O Module
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The SNMP PremNet ATM I/0O Module enables you to send and receive short, fixed-
length packets called “cells” using the ATM transport. The SNMP PremNet 5000
accepts cell traffic from your premise and carries that traffic back into the carrier’s
backbone ATM network. The ATM I/O module provides a signaling protocol interface
that complies with ATM Forum’s User Network Interface (UNI) standard. Although
cells carry the data over the ATM interface, the internal transport of the data in the
SNMP PremNet system is circuit-based. You define the bandwidth that is allocated to
carry the traffic between SNMP PremNet nodes.
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Link Modules

SONET/SDH Link Module

Synchronous Optical Network (SONET) is the data transmission standard used in the
United States, and Synchronous Digital Hierarchy (SDH) is the standard used in Europe.
The SONET/SDH link module converts SNMP PremNet backplane data into SONET or
SDH frames (the mode is software-selectable), which are transmitted at 155 Mbps over
fiber optic cable.

T3 Link Module

The T3 Link module converts PremNet backplane data into the DS3 framed signal. The
DS3 frames are transmitted and received at 44,736 Mbps over 75Q coaxial cable.
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Chapter 2
Managing the SNMP PremNet 5000
Network

Introduction

This chapter discusses how to configure and manage the SNMP PremNet 5000 System
and establish connections between the modules.

Before you can configure the system, you must perform the following tasks:

* Set the dip switches on the ENMM. Refer to Chapter 4 of the PremNet 5000
System Installation and Configuration Manual.

* Verify that the nodes are linked together using fiber-optic cable or T3 coaxial
cable and the common modules are properly installed in the nodes.

* Power up each SNMP PremNet 5000 node and check that no red LEDs are lit.

* Connect the management station to the ENMM (see the following procedure).

Connecting the Management Station

Before you can use the workstation to manage the SNMP PremNet 5000 System, you
must complete the following steps. The procedural differences for the CMS 400 and HP
OpenView management platforms are described.

1. Specify the IP address for SNMP. Refer to Chapter 5 of the PremNet 5000
System Installation and Configuration Manual for instructions.

2. Create a database for the SNMP PremNet 5000 System. Refer to the CMS 400
User's Guide or the HP OpenView for Windows User’s Guide to create a
database.

3. Define the SNMP PremNet ring to the database via the procedures applicable to
your environment, which are explained next.
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Adding SNMP PremNet 5000 to the Database

2-2

Via CMS 400

The SNMP PremNet 5000 Master Node (Node 1) is defined by the IP address of the
System Master Node. The CMS 400 system can be used to manage all nodes in the
SNMP PremNet 5000 network.

To add a SNMP PremNet 5000 Network to the CMS 400 database:

1. Select Database from the menu.

2. Select Network Map from the Database menu or click on the Network Map Icon
on the toolbar.

3. Select Insert.
The Insert New Unit screen prompts for the address.

The SNMP PremNet 5000 Master Node should be defined completely, with an
IP Address and the name of the node. The other SNMP PremNet 5000 nodes in
the network are automatically defined by the master node.

4. Set Diagnostic Protocol to SNMP.
Via HP OpenView

Use the HP OpenView Autodiscovery feature to automatically add PremNet units to the
database. The HP OpenView Autodiscovery mechanism “discovers” the PremNet
devices and displays them on the maps with “PremNet” icons. The PremNet device can
be added to the database by two methods:

From the Autodiscovery menu:

1. Select Discovery Manager from the Discover submenu. This is the preferred
method.

or
2. Select User-Specified Device from the Configure submenu.

The Autodiscovery function also allows you to specify subnetworks to search and routers

to work with. For complete information about using the Autodiscovery feature, refer to

the HP OpenView for Windows User’s Guide.

The attributes may be viewed by either selecting:

¢ Describe from the Edit menu or

* Right-clicking the PremNet icon and selecting the Describe option with the left
mouse button.
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HP OpenView - Milgo Customizing

Customize Milgo Management
HP OpenView’s main menu bar includes a Milgo-specific choice in the Options menu,,
Customize Racal selection. This selection presents a dialog with a grouping called Third
Party Application Names. The operator uses this dialog to specify local applications to
launch from within Milgo applications and menus.
Three fields are presented:

1. Telnet Application

2. Ping Application

3. TFTP Application

Note: The PremNet Manager does not support Telnet or TFTP applications.

In all cases, the dialog text instructs you to place the token “%Ss” after the path name as a
holder for the IP address of the target unit. The parameter passes the address to the
application that is launched. A browse button accompanies each field for convenient
selection of an executable file. Refer to the Racal Device Managers for HP OpenView
for Windows Installation Instructions guide.

Login Security Levels

HP OpenView also offers a three-level security mechanism: a supervisor level that can
do anything, an observer level that can view but make no changes, and an operator level
that can make changes but cannot reconfigure HP OpenView options.

The popup menu that launches the PremNet 5000 Manager is aware of your login

privilege level, and offers only those choices that can be legitimately performed. Table
2-1 lists the applications and the security levels at which they can be executed.

Table 2-1. Login Security Levels

Supervisor Operator Observer Application
X X Configure PremNet
X X X Ping SMN
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Verifying Communication

Once the SNMP PremNet 5000 network is defined in Network Map and is physically
connected to the channel, verify that the CMS 400 or HP OpenView system can
communicate with the SNMP PremNet 5000 Master Node.

Via CMS 400

1. Place the cursor on the master SNMP PremNet 5000 Master Node in Network
Map.

2. Click on Poll.

If CMS 400 can communicate with the master node, the message Target Device
Responds to Poll is displayed. If it cannot, Target Device Does Not Respond is
displayed.

Via HP OpenView

1.  Double-click with the left mouse button on the PremNet icon in the HP
OpenView Submap view. A popup menu offers the following choices:

Configure PremNet
Ping SMN

2. Click on Ping SMN.

If the HP OpenView system can communicate with the master node, the message Target
Device Responds to Poll is displayed. If it cannot, Target Device Does Not Respond is
displayed.

Device settings and other device information are available as variables and are defined
either in a standard Management Information Base (MIB) file or in a custom MIB file
provided by the device manufacturer. For more information about the Milgo MIB
inclusion, refer to the Racal Device Managers for HP OpenView for Windows
Installation Instructions guide.

Displaying the SNMP PremNet 5000 Network

The SNMP PremNet is displayed at three levels:
e Multi-Ring Level

* Single-Ring Level
* Node Level
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Multi-Ring Level Display

To display the SNMP PremNet 5000 at the multi-ring level:

1. Select LAN Control from the Commands menu in CMS 400 (refer to Figure 2-1).

— CMS 400
File View EWiILLELLEN Options
. Database
= Monitor » =
o [ Test » ’E T B
WAN Control
LAN Control Generic SNMP Control
Configuration SNMP Top-16 Monitor
Bestoral INX5000 Hub Control
Automation INX NTS Control
Report INX T-Ring CAU Control }
Administration INX Managed Repeater
Workstation INXA4000 Bridge Control
Applications RNXEx00 Bridge/Routers

RMNx6300 User Console
RACAL-DAT PremMNet Control

PremMNet SNMP Control

EAN 2000 Control
Wellfleet Control
InterLanLink Stackable Hub

Figure 2-1. CMS 400 Commands Menu

2. Select PremNet SNMP Control. The “Select One Or Many Units By Criteria”
dialog box appears. Refer to Figure 2-2.
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= Select One Or Many Units By Criteria

Figure 2-2. Select Units By Criteria

3. Select Unit from the dialog box. The available units are listed (refer to Figure 2-
3).

— Select Units For Criteria

Freamil=t_ 1 FPremil=t_ 02

-
—

Figure 2-3. Select Units For Criteria

4. Select the unit desired by clicking on it, and select OK.

The “Select One Or Many Units By Criteria” screen reappears with the name of
the selected unit. Refer to Figure 2-4.

2-6



Managing the SNMP PremNet 5000 Network

= Select One Or Many Units By Criteria |

UNI=PREMNET

Figure 2-4. Unit Selection
5. Click on OK to select the unit.

The program reads the unit’s system variables, then displays the MultiRing
View (refer to Figure 2-5).

Note: Any node in alarm displays its number in RED.

PremMet_01 : MultiHing View
Edit Yiew Tools

d_h

Figure 2-5. MultiRing View
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Single-Ring Level Display

2-8

To display the SNMP PremNet 5000 at the single-ring level, choose one of the following
methods:

Select a single ring by double-clicking on it from the MultiRing view, or select
Single-Ring from the View menu, or click on the Single-Ring icon.

When the Single-Ring dialog box appears, highlight the desired ring and select
OK.

Note: You must highlight the selection before selecting OK even if there is only one
ring listed. If not, an error message appears.

The ring explodes to fill the window with the nodes for that ring (refer to Figure 2-6).

The initial Single-Ring display shows empty boxes. As the data is returned from polling,
the boxes are filled. This adds detail (nodal links, switching modules, and I/O modules)
and status to each node on the ring.

This gives you a snapshot glimpse of the ring and all the nodes on that ring. At any
point during the filling in of the detail, you can select a node for explosion, or back out
to the MultiRing display (or any of the other tools provided by active toolbar icons and
menus).

Note: Any node in alarm displays its number in RED.
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FremMet - Hing Yiew

EEREERE

Figure 2-6. Single-Ring View

Refer to Tables 2-2, 2-3, and 2-4 for descriptions of the color codes in the Single-Ring

Display.
Table 2-2. SNMP PremNet Ring Display
Component Window Display
Tag Name Node Title is the Tag Name. Node’s ring-node
identification displays immediately above the nodes icon.
Link Module Cards Displayed as separate transmit and receive boxes
(A/B/C/D) within each node.
Switch Cards Displayed as individual boxes (SxA, SxB) within each
node.
1/0 Cards Displayed as eight individual slots with a common
connection to the active switch within each node.
Fiber data flow Displayed as arrows emanating from the link module
between nodes transmit box of one node and terminating at the
corresponding link module receive box of the next node.

Each box within a node is color-coded to reflect the associated component’s status (refer

to Table 2-3).
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Table 2-3. SNMP PremNet Ring Display Component Status

Color Link/Switch Module 1/0 Slot
Green Card is active Circuits are active
Blue Card is in standby No active circuits
Red Card is in alarm Card is in alarm
White Card not present Card not present

The dynamic data flow changes within a ring are described in Table 2-4.

Table 2-4. SNMP PremNet Ring Display Dynamic Data Flow

Condition

Effect on Display

Loss of Internode
Connection

Boxes representing the corresponding transmit and receive
link modules of the affected nodes turn red.

Redirection of the affected node’s internal data flow arrows
between the switch and link modules.

Power Down of Node

The node goes completely white. Link flow adapts to a new
route.

Active Switch Change

The switched card changes color according to what was
switched in the active node. Arrows representing internal
data flow within the node adapt to the use of the new switch
card.

If the ring is configured for redundant operation, the arrows representing data
flow between node link modules will all go in the same direction. If the ring is
configured for counter-rotating operation, these arrows go in the appropriate

direction.

Note: There is a separate window per ring. Up to 16 nodes can be displayed on one
ring, with up to 16 ring modules for multi-ring configurations.
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Node Level Display
To display the SNMP PremNet 5000 at the node level:

1. In the Single-Ring level view, move the arrow or cursor to the node you want to
view.

2. Click on the node to select it. Notice that its color changes when selected.

Note: The node selection must be completely colored for you to view the node level.

3. Select Node from the View menu, click on the Node icon, or click on the node
picture again.

The node view is displayed (refer to Figure 2-7).

PremNet_01 : Node Yiew

File Edit Yiew

Ring 1. Mode 1

Figure 2-7. SNMP PremNet Node View

Note: Any modules in alarm appear in RED.
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Service Affecting Commands

Service-affecting commands affect the flow of data in the SNMP PremNet 5000
network. These commands are displayed as settings in dialog boxes when you select
Configure from the Tools menu. Warnings similar to the one in Figure 2-8 may be
displayed at the network configuration, ring configuration, and node configuration levels
described in this section.

Warning: Use extreme caution when changing any of these configuration settings

= Metwork Configuration Yarning |

ol OF

| fres | [ Mo

Figure 2-8. Configuration Warning

Select No to return to the configuration box, or select Yes to accept the changes.

Network Configuration (Service Affecting)
To view the network configuration:
1. Display the MultiRing view.

2. Select Configure from the Tools menu or click on the Configure icon. The
Network Configuration (Service Affecting) box appears (refer to Figure 2-9).

= MNetwork Configuration [Service Affecting) |
Multi Node - Multi Ring B

| ok ][ Cancel

Figure 2-9. Network Configuration (Service Affecting)
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3. View the current setting in the Ring Configuration field. The selections are as
follows:

* Single Node

* Multi Node-Single Ring
* Multi Node-Dual Main
* Multi Node-Multi Ring

4. Select Cancel to return to the Multi-Ring view.

Note: If you make a change and select OK, Figure 2-8 appears.

Ring Configuration (Service Affecting)
To view a ring configuration:
1. Display the Single-Ring view.

2. Select Configure from the Tools menu or click on the Configure icon. The Ring
Configuration (Service Affecting) box appears (refer to Figure 2-10).

RHing Configuration [Service Affecting)

Countor Rotating ——__[&
Momt Msgz on AB Ring |_

Do Mot Save Current Ring I]n:IE|

Figure 2-10. Ring Configuration (Service Affecting)
3. View the current setting in the following fields:
* Ring Option
Redundant or
Counter Rotating
* Management Ring

Mgmt Msgs On AB Ring or
Mgnt Msgs On CD Ring
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* Save Current Ring Order
Do Not Save Current Ring Order or
Save Current Ring Order

4. Select Cancel to return to the Single-Ring view.

Note: If you make a change and select OK, a Ring Configuration Warning appears
(similar to Figure 2-8).

Node Configuration (Service Affecting)
To view a node configuration:
1. Display the Node view.

2. Select Configure from the Tools menu or click on the Configure icon. The Node
Configuration (Service Affecting) box appears (refer to Figure 2-11).

= Mode Configuration [Service Affecting] |

Systom Moster Node |8
[ETS
Swcha @
Rodundert |8

20 TimeSlots E3
Do Not Reassion &

Figure 2-11. Node Configuration (Service Affecting)
3. View the current setting in the following fields.

* Node Type
System Master Node
Interconnect Node Child Ring AB
Interconnect Node Child Ring CD
Network Node

2-14



Managing the SNMP PremNet 5000 Network

e Active Link
Link A
Link B
Link C
Link D

¢ Active Switch
Switch A or
Switch B

» Switch Configuration
Redundant or
Single

e BackPlane TS Mode

Link A-C
Link A-D
Link B-C
Link B-D

20 Time Slots or

30 Time Slots

* TS Reassignment

Do Not Reassign or

Assign

4. Select Cancel to return to the Node view.

Note: If you make a change and select OK, a Node Configuration Warning appears

(similar to Figure 2-8).

Configuring Connections

Connections are used to create logical paths between I/O modules within a network.
This procedure describes how to add, modify, and delete a connection between two of
the same type of modules installed in two separate nodes.

To configure connections from the Ring View:

1. Select Connections from the Tools menu or click on the Connections icon from
the toolbar. This provides a dialog box to configure connections and timeslot

data.

The Connection Configuration screen appears. See Figure 2-12.
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= Connection Configuration |

Figure 2-12. Connection Configuration
There are two methods of configuring connections. One method is to use the dialog box.
The other is to use a graphical representation of the network. Select Display Connections

Graphically from the Connection Configuration Display to view the graphical display
screen. Both methods are described.

Adding New Connections
To add new connections:

1. Select Add from the Connection Configuration screen. The Connection Name
screen appears (refer to Figure 2-13).

— Connection Name

| ok || cancet

Figure 2-13. Connection Name

2. Enter a connection name, if desired, or click on OK to accept the default name.
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Adding Connections Using The Dialog Box

When the Adding New Connection dialog box appears, follow the procedure in this
section (refer to Figure 2-14).

= Adding New Connection

—
—

High Perf Ethemnet
High Perf Ethermnet
High Perf Ethemnet
High Perf Ethernet
High Perf Ethemnet
High Perf Ethemnet
High Perf Ethemet

Figure 2-14. Adding New Connection
1. Select a module from the Available Modules box.
2. Click on the Left Arrow to move the module to the Participating Modules box.

The list of modules in the Available Modules box is narrowed down to only the
modules of the same type as the one selected.

Note: Double-clicking on a module name moves it to the opposite box.

3. Move any other modules over to the Participating Modules box to create your
connection.

4. Click on OK. The Connection Configuration screen appears.

5. Click on Process Connects to establish the connection.

Adding Connections Graphically
The graphic representation of the network is color-coded (refer to Figure 2-15). As you

point the arrow on a slot, its description is displayed on the bottom of the screen. Each
slot displays one of the following colors:
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* Cyan This slot is available and qualified to use in a connection.

* Yellow This slot is available but not qualified to use in a connection.
* Red This slot is used in another connection.

* Blue This slot is now ready to connect.

Note: These colors change as you build the connections.

1. Select a cyan-colored slot by clicking on it. The card in that slot is displayed at
the bottom of the screen. After clicking on a cyan slot, it turns blue. This means
it is now in the connection.

2. Select other cyan cards you want in your connection and click on them. Those
slots turn blue.

The only slots that contain the same type of card are cyan. All other slots have
turned yellow.

3. Click on OK when you have finished creating that connection. The Connection
Configuration screen appears.

4. Select Process Connects to save the connection.

Adding New Connection: net 3

File Edit Yiew Tools

Card Type: Mo Cards in net 3
TimeSlots: Any

ok | [cance

- mmmm

. ]

Figure 2-15. Adding New Connection (Graphical)
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Modifying a Connection

To modify a connection:

1.

Select Connections from the Tools menu, or click on the Connections icon from
the toolbar. The Connection Configuration dialog box appears.

Highlight the connection name you want to modify.

. Select Modify from the Connections dialog box.

The Modifying Existing Connection screen or its graphical counterpart appears
(refer to Figure 2-16 or Figure 2-17).

Modify your existing connection by moving participating and available modules.

. Select OK when finished. The Connection Configuration screen appears.

. Select Process Connects to establish the connection.

Modifying Existing Connection

—
—

01 01 3 (2] Ethernet B
01 057 (2] Ethernet B
01 07 7 (2] Ethernet B

Figure 2-16. Modify Existing Connection
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Modifying Existing Connection: test
View Tools

Card Type: Mo Cards in test
TimeSlots: 1

- mmmm
o n.m.
Ringlﬁm...

Figure 2-17. Modifying Existing Connection (Graphical)

Deleting a Connection
To delete a connection:
1. Select Connections from the Tools menu, or click on the Connections icon.
2. Select the connection you want to delete, and select Delete from the screen.

The Deleting Existing Connection screen or its graphical counterpart appears
(refer to Figure 2-18 and Figure 2-19).

3. Select OK from this screen.

4. Select OK from the “Are you certain?” screen. The Connection Configuration
screen appears.

5. Select Process Connects to discontinue the connection.
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= Deleting Existing Connection

|
——

01 01 3 (2] Ethernet B
01 05 7 (2] Ethernet B
01 07 ¥ (2] Ethernet B

Figure 2-18. Deleting Existing Connection

Deleting Existing Connection: software
File Edit View

ard Type: Ethernet B
TimeSlots: 2

(%]

e (R

Figure 2-19. Deleting Existing Connection (Graphical)
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Renaming a Connection
To rename a connection:
1. Select Connections from the Tools menu or click on the Connections icon.
2. Select the configuration to rename from the Connection Configuration screen.
3. Select Rename. The Connection Name screen appears.

4. Type in the new name, and click OK. The Connection Configuration screen
appears.

5. Select Process Connects to save the configuration.

Tools

Selections available in the Tools menu, and in tool icons on the toolbar, enable you to
properly manage the SNMP PremNet 5000 Network. The Tools menu is available at all
viewing levels.

= Multi_Ring_1: MultiRing View

File Edit Yiew BILLE

EE R e

Cance|
Refresh

Monitor
Status
Details

Test
Connections
Configure

Criteria
Ping SMN
Direct SNMP

Beports ... »

E

Figure 2-20. Tools Menu
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Alarms

Note: Certain menu selections may be grayed out because they are not applicable at a
particular viewing level. For example: the Test tool will be grayed out at the MultiRing,
Single-Ring, and Node levels. This is because tests apply to specific I/O and link
modules. Also, if an I/O or link module has no integral test, the test tool will not be
available. See Chapter 3, “Managing Specific I/O and Link Modules”, for additional
information.

The following paragraphs give a brief description of the tools in the Tools menu.

You can display alarms generated by the system or the SNMP PremNet network.

When the Alarm item is selected from the Tools menu or from the tool bar (Bell icon),
the Alarm Selection dialog box gives you the option to select (refer to Figure 2-21):

= Alarm Selection

Figure 2-21. Alarm Selection
* PremNet Alarm Log (queries the PremNet SNM log) or

e CMS 400 Alarm Log (spawns CMS 400’s or HP OpenView’s system alarm
display)

The system displays the actual alarm logs, both current and history, for each level of
display (refer to Figure 2-22).

The SNMP PremNet network displays alarms at any network level. Also, an alarm
history is available. Alarms appear at the level viewed and below. For example: If you
select Alarms at the single ring level, you can view the alarms for the ring and its nodes
and modules.

No alarms are displayed for any other nodes or rings in the network. Refer to
Figure 2-22 for an example of an alarm screen.
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= Current Alarms For Ring 1

MNoda 01 I/0 moechule 2 alarm

Figure 2-22. Alarm Display

Monitor
Use the Monitor tool to monitor the traffic on the module. An example of using this tool

is to monitor LAN traffic on a particular module for errors. Refer to Figure 2-23 for an
example of a monitor display screen.
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= Token Ring Monitor

10:03:22 26-Mar-95
8:12:07 27-Mar-95

Figure 2-23. Token Ring Monitor Display

Status

Use the Status tool, for example, when you want to check the status of a particular
module. Refer to Figure 2-24 for an example of a status display screen.

— Card Status

i

—

Figure 2-24. Card Status Display

Details

Use the Details tool, for example, to view specific details of a module. Refer to
Figure 2-25 for an example of a details display screen.
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— Details Of Card |

i

—

Figure 2-25. Details Display Screen

Test

Use the Test tool to perform applicable tests on specific modules and ports of modules.
Remember that not all modules have integral tests, therefore the test tool is grayed out if
tests are not applicable. Refer to Figure 2-26 for an example of a test screen display.

= Token Ring Test |

——

Figure 2-26. Token Ring Test Screen Display

Connections
Use the connections tool to add, modify, delete, or rename connections between specific

modules in the network. Refer to “Configuring Connections” described earlier in this
chapter for more information.

Configure

Use this tool to configure parameters on a specific module or port on a module. Refer to
Figure 2-27 for an example of a configuration screen display.
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Criteria

Ping SMN

= Token Ring 4f16 Card Configuration

—
Unlocked [ |

Uniocked T 16 Mbps |88
Unlocked [ Locked ][
Unlocked [ Loopback &

Figure 2-27. Configuration Screen Display

Unit, Site, and Group

Use the criteria tool to select the Criteria screen, which allows you to select one or many
target unit(s) to be used by the application. You create a criteria string which represents
a unit or a set of units.

The applications perform their associated functions on all units that match the specified
criteria. When you select one of these criteria, then channels, units, sites, or groups on
your specified hub are displayed. Select the criteria applicable to your application. Refer
to “Multi-Ring Level Display” earlier in this chapter.

Via CMS 400

Use the Ping tool to Poll the System Master Node (SMN) with an ICMP PING packet.
The status message at the bottom of the screen displays whether the device responded or
not.

Via HP OpenView

This menu option launches the user-chosen Ping utility (if any) named in the Ping
Application field in HP OpenView’s Options menu, Customize Racal selection. A
warning message is issued if no such utility is specified.
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Direct SNMP
Via CMS 400

Use the Direct SNMP tool to activate the Direct SNMP application. The target unit is
displayed to allow access to MIB variables (refer to Figure 2-28). Table 2-5 explains the
Direct SNMP functions.

Via HP OpenView

Direct SNMP invokes the HP OpenView SNMP Manager-Define Query function for
direct SNMP polls to the PremNet 5000 Manager. Refer to the HP OpenView for
Windows User’s Guide for direct SNMP control.

— PREMMET - Generic SNMP Control: Unit PremMNet
File Edit Help

Uit Hame Pro
T

[P Add

Figure 2-28. Direct SNMP Control Screen
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Table 2-5. Direct SNMP Control

Selection

Function

Ping

The System Master Node (SMN) is polled with an Internet Control
Message Protocol (ICMP) ping packet. A message appears
indicating whether the unit responded or not.

Alarms

Indicates the date and time of any alarms.

Monitor

Shows a screen to allow setting of monitor options.

Configure

Selects a MIB (Management Information Base) to configure.

Fetch

Fetches objects with a selected MIB.

Telnet

Enables access into Telnet.

Dump

Displays MIB Objects for a selected unit.

IPCache

Displays the IP Address of the unit selected.

Cancel

Use the Cancel tool to terminate other tools already in progress. For example, select
Cancel when you want to stop gathering information for a report.

Refresh

Use the Refresh tool to gather slot information again if needed. For example: Use this
tool when adding or deleting modules in a node. Refer to Figure 2-29.

= Hefresh Topology |
i

es | [ wo

Figure 2-29. Refresh Topology
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Reports

Use the Reports tool to generate reports about the network. Refer to Chapter 4,
“Reports”, for generating network and nodal reports.

PremNet Trap Handling

2-30

Traps are unsolicited messages (containing management information) generated by an
SNMP agent to inform the SNMP client (management station) about a notable event or
change of state, for example: coldstart, link failure, threshold exceeded, shutdown, etc.
PremNet 5000-specific traps are issued through the master node ENMM. The
differences between CMS 400 and HP OpenView are described.

Via CMS 400

All of the PremNet traps are mapped to the Service Request (SRQ) alarm. Each alarm
contains detailed textual information in the parameters field describing the alarm
condition. Refer to the CMS 400 User’s Guide for trap handling and alarms, and
Appendix B for alarm code diagnostics.

Via HP OpenView

The HP OpenView alarm subsystem provides a central logging and event monitoring
facility for all HP OpenView applications. When an alarm is generated, it is assigned
one of 10 severity levels. HP OpenView can show the alarm condition on the map by
changing the background color of the map symbols. Alarms are saved in an alarm log.
An alarm log window allows you to view the logged alarms or events. Alarms remain in
the current alarm log until acknowledged programmatically by the PremNet application.
Once acknowledged, alarms are saved in the history log for a configurable period of
time, after which they are deleted. Refer to the HP OpenView User’s Guide for more
information about trapping and alarms.



Chapter 3
Managing Specific I/0 and Link Modules

Introduction

This chapter describes the specific configuration features of the various I/O and link
modules. Follow the procedures within this chapter to configure and manage specific
I/O and link modules.

Displaying a SNMP PremNet 5000 I/O Node

From the SNMP PremNet 5000 Single-Ring level screen, you can display a detailed
graphic representation of a single node. From the node level, you can go one step further
and display each module in that node.

Node Level Display
To display the SNMP PremNet 5000 at the Node level:

1. Move the arrow or cursor to the node you want to view in the Single-Ring level
view.

2. Click on the node to select it. Notice that its color changes when selected.

3. Select Node from the View menu, click on the Node icon, or click on the node
picture again.

The node view is displayed (refer to Figure 3-1).
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PremNet : Node Yiew

File Edit Yiew

Figure 3-1. SNMP PremNet Node View

Displaying a SNMP PremNet 5000 I/0 Module

Select a module from the Node View by clicking on it. The module color changes to a
darker gray.

From this level, you can perform various operations on the module by selecting Tools

from the Tools menu or clicking on the operation from the toolbar (non-applicable
operations are grayed out).

Displaying the Port Level of an I/0 Module
To perform operations from the port level of a module:
1. Click on the specified module from the displayed node view.
2. Click on the port desired. The selected port color changes to a darker gray.

A screen similar to Figure 3-2 is displayed.

3-2



Managing Specific I/O And Link Modules

= PremNet_01 : Port View
File Edit View Tools

-] =R &Em [

Ring 1, Moda1

CCTCCICTCTCTT
) [

Figure 3-2. Port Level Screen

3. Choose the applicable operation from the Tools menu or toolbar.

Tools Menu for I/0 and Link Modules

Some tool menu selections do not apply to all levels of the network. If a selection is
grayed out, it does not function at that particular level. For example, some I/O and link
modules allow you to monitor traffic, while others do not.

Depending on the module, configuration can be selected at the module or port level.
Refer to Table 3-1 for which modules apply to which functions in the tool menu.

¢ A M indicates module level.

* A P indicates port level.

3-3



SNMP PremNet 5000 Manager for Windows User’s Guide

Table 3-1. Tools Menu

I/0 or Link Tools Menu
Module Selections
Monitor Status Test Configure
Ethernets M M M
4 Mbps M M M
Token-Ring
4/16 Mbps M M M M
Token-Ring
Token-Ring M M
MAU
RS-232 P P M-P
RS-232 M-P M-P
Multi-Port
RS-422 M-P
V.35 M-P P P
4-Wire Voice M-P P P P
Video M M
T1/E1l M-P M P P
3270 M-P
5250 M-P
ATM M M
SONET M
T3 M

Note: Alarms and Detail are applicable to all I/O and link modules. Connections,
Criteria, Ping SMN, and Direct SNMP apply at all levels of the SNMP PremNet 5000
network.
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1/0 Modules

There are eight I/O slots on an SNMP PremNet 5000 node. Any I/O module can be
installed into any one of the eight slots. The following paragraphs describe how to
configure and manage each of the currently available I/O modules.

Ethernet I/0 Module

The Ethernet I/O Module provides a full-forwarding (non-filtering) bridge function that
enables you to connect multiple Ethernet segments. These segments then appear as one
logical segment, with all traffic from any one segment appearing as traffic on all other
connected segments.

This section describes how to configure and manage the Ethernet I/O module.

Configuration Strategy

This procedure provides an overall strategy when configuring a new Ethernet I/O
module into an existing network. The steps are listed below, after which each step is
explained in detail.

1.

Establish point-to-point connections between the new Ethernet I/0
Modules. You can connect up to 32 Ethernet I/O Modules in the same
connection. There should be no external equipment attached to the Ethernet I/O
Modules at this point. Refer to “Configuring Connections” in Chapter 2.

Access one of the new Ethernet I/O Modules. Refer to “Displaying a SNMP
PremNet 5000 I/0O Module” within this chapter.

Test the new Ethernet I/O Module. Refer to “Fiber Backbone Test” within
this section.

Check the traffic statistics. While the backbone test is running, monitor the
module. Refer to “Monitoring Statistics” within this section.

The traffic statistics displayed should report 128 frames per second transmitted
and received on the fiber backbone.

Check each Ethernet I/0O Module in the connection. The traffic statistics
displayed should report 128 frames per second received from the fiber backbone.
Additionally, the module should display 128 frames per second transmitted onto
its local Ethernet segment, provided that the segment is properly terminated.
Refer to “Monitoring Statistics” within this section.

Stop the backbone test on the local I/O module. Refer to “Halt Current Test”
within this section.
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10.

11.

. Connect the cable to the port. Once each of the connections has been

established and verified, connect the cables to the appropriate port on each of the
Ethernet I/O Modules in the connection, and then complete the following
procedure:

¢ Select one of the Ethernet I/O Modules.

» Select Configure and choose the appropriate port for that module. Refer to
“Configuring the Module” within this section.

Reset the traffic and error counters. Refer to “Resetting Counters” within this
section.

Monitor the traffic on the Ethernet segment and the fiber backbone. Refer
to “Monitoring Statistics” within this section.

If the segment has live traffic, the following information is displayed:
* The number of packets received every second for that segment.

* The number of packets transmitted onto the segment every second is also
displayed for other segments connected elsewhere in the system.

* Backbone traffic (receive and transmit) is displayed if any traffic is received
from or transmitted onto the local Ethernet segment.

» If one or more errors display, stop the Monitor display and change the port
type to AUl or Ext Bridge (whichever port is not being used) to avoid
corruption of the Ethernet network.

Check for errors on either the backbone or Ethernet segment.

Before you begin using the modules, reset the traffic and error counters.
Refer to “Resetting Counters” within this section.

Configuring the Module

This option allows you to select the connection to the Ethernet I/O Module.

1. Select the Ethernet I/O Module as described previously.

2. Select Configure from the Tools menu or click on the Configure icon.
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3. Select the interface port type from the dialog box in Figure 3-3 as follows:

To activate the ... Select ...
AUI port AUI

Thin Ethernet port Thinnex coax
MAU port Ext Bridge

4. Select OK to save the configuration.

Caution: If you change the port type while live data is being exchanged, the flow of
data will be disrupted. Disconnect any cable to the module before you change the port
type. After the new port type has been selected, reconnect the cable to the selected port.

= EtherNet Configuration |

—

Figure 3-3. EtherNet Configuration

Monitoring Statistics

This procedure allows you to monitor traffic on the backbone and the segment. The
transmit and receive frame information and the number of frame errors detected are
continuously displayed and time-stamped for reference.

From the Ethernet I/O Module:

1. Select Monitor from the Tools menu or click on the Monitor icon. The Ethernet
Monitor screen appears. See Figure 3-4 for an example. Table 3-2 explains the
fields.

2. Select Fiber/Segment from the lower left corner of the Fiber screen to view the

statistics of the applicable test. The current test name appears at the top of the
screen.
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3-8

Ethernet Monitor: Fiber
128 @ 15:11:49 14 Aug 1996
0.0% @ 13:44:00 30 Aug 1996
@ 13:44:02 30 Aug 1996
@ 13:44:03 30 Aug 1996

@ 16:25:06 28 Aug 1996

Figure 3-4. Ethernet I/O Module Monitor Screen

The following example explains how to interpret the data in the Errored Seconds,
Errored Minutes, and Errored Hours fields.

Example:
The error counters were reset 10 hours ago.

1. Check the Errored Hour field. If the value in the field is 10, at least one error
has occurred every hour for the past 10 hours.

2. Check the Errored Minutes field. If the value in the field is 60, at least one error
occurred in any given minute, for a total of 60 minutes within the last 10 hours.

3. Check the Errored Seconds field. If the value in the field is 900, at least one
error occurred in any given second, for a total of 900 seconds (15 minutes)
within 60 minutes within a 10 hour span.

Missed Frames, Overflows, Under flows, and Bad Frames show the total number
of each of these kinds of errors that have occurred since the counts were last
reset.
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Table 3-2. Ethernet I/O Module Monitor Field Descriptions

Field Name

Description

Rx Frms/Sec Now

The average number of frames per second in which frames of received data
have been detected since the counts were last reset.

Rx Frms/Sec Peak

The highest number of frames per second in which frames of received data
have been detected since the counts were last reset.

Rx Utilization Now

The average percentage of the total Ethernet bandwidth being used by the
traffic received from the Ethernet segment or from the backbone since the
counts were last reset.

Rx Utilization Peak

The highest percentage of the total Ethernet bandwidth being used by the traffic
received from the Ethernet segment or from the backbone since the counts were
last reset.

Max Rx Frm Size

The maximum frame size since the counts were last reset.

Min Rx Frm Size

The minimum frame size since the counts were last reset.

Errored Hours

The number of hours in which errors have been detected since the counts were
last reset.

Errored Minutes

The number of minutes in which errors have been detected since the counts
were last reset.

Errored Seconds

The number of seconds in which errors have been detected since the counts
were last reset.

Last Error At

Displays the time/date that the last error (or errors) was detected.

Missed Frames

The total number of missed frame errors which have been detected since the
counts were last reset.

Overflows The total number of overflow errors which have been detected since the counts
were last reset.

Underflows The total number of underflow errors which have been detected since the
counts were last reset.

Bad Frames The total number of bad frame errors which have been detected since the counts

were last reset.

Resetting Counters

Select Reset Counts from the Ethernet Monitor screen to reset the counts to zero.
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Performing Tests

3-10

The Test option allows you to test a new Ethernet network before live data is sent onto it.
Test traffic can be generated onto the local Ethernet segment or onto the PremNet 5000
fiber backbone.
To initiate a test:

1. Select the Ethernet I/O Module as described previously.

2. Select Test from the Tools menu or click on the Test icon.

The system polls the module for the current test status. A Progress box appears
showing the percentage of data read.

3. Select one of the options from the Ethernet Test selection box in Figure 3-5. The
choices are:
* Local Segment Test
» Fiber Backbone Test

e No Test

= EtherNet Test
Local Segment Test |_

[
[
| ok | [ Concet

Figure 3-5. Ethernet Test Selections

Local Segment Test

This option generates test traffic on the Ethernet I/O module. You can direct the
module’s output into another module to simulate live traffic to test that module and all
the other modules in a connection. Or, you can direct the output onto your own Ethernet
network to generate test traffic. The test traffic generated will have no adverse effect on
the network other than to increase the traffic volume, which in itself may cause problems
on the network. Care must be taken to avoid overburdening a live network with test
traffic.
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To initiate the test:
1. Select Local Segment Test from the Test selection screen.
2 Enter a number from 10 to 85 in the Load % field.
3 Enter a number from 81 to 1724 in the Frames/Sec field.

4. Select OK to start the test (refer to Figure 3-6).

= EtherNet Test
Local Segment Test |_

[
[
| ok | [ Concet

Figure 3-6. EtherNet Test

While the test is running, the values you entered at the Load % and the
Frames/Sec fields appear on the screen. The bytes per packet (which is
calculated automatically from the load percentage and number of packets per
second) is displayed in the Frm Size field.

For example, if you entered 30% traffic load at a rate of 3000 packets per
second, the number of bytes per packet is 117. (This packet size includes source
and destination addresses, type field, data field, and FCS bytes.)

5. Select Node View to display the front view of the SNMP PremNet node.

6. Select and monitor the module that is receiving the test traffic to ensure proper
module operation. Refer to “Monitoring Statistics” within this chapter.

You can also monitor other modules in the connection to ensure system
integrity.
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Fiber Backbone Test

This option is used to test the Ethernet I/O Module's ability to transmit Ethernet packets
over the backbone to another Ethernet I/O Module in the connection.

Perform this test for each Ethernet I/O Module in each connection to verify the integrity
of the connection before it is used to transport live data.

To initiate the test:
1. Select Fiber Backbone Test from the Test selection screen.
A message is displayed indicating that the test is in progress.
2. Select Node View to display the node.

3. Select and monitor the module that is receiving the test traffic to ensure proper
module operation. Refer to “Monitoring Statistics” within this chapter.

You can also monitor other modules in the connection to ensure system
integrity.

Halt Current Test

This option stops whatever test is running at the time. It must be chosen before you can
move from one test to another. You must stop all tests before connecting active Ethernet
devices to the Ethernet I/O modules.

To stop a test, select Cancel from the Tools menu or click on the Cancel icon.

High-Performance Ethernet I/O Module

The High-Performance Ethernet I/O Module provides full bandwidth Ethernet remote
connectivity between Ethernet segments or networks connected to the SNMP PremNet
5000 System.

This section describes how to configure and manage the High-Performance Ethernet /O
Module.

Configuration Strategy
This procedure provides an overall strategy when configuring a new High-Performance

Ethernet I/O Module into an existing network. The steps are listed below, after which
each step is explained in detail.
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. Establish a connection for the new High-Performance Ethernet I/O Module.
You can connect up to 32 High-Performance Ethernet I/O Modules in the same
connection. There should be no external equipment attached to the High-
Performance Ethernet I/O modules at this point. Refer to “Configuring
Connections” in Chapter 2.

. Access one of the new Ethernet I/0 Modules and check the configuration.
Refer to “Displaying a SNMP PremNet 5000 Module” within this chapter.

Check that the Port Type field - in the EtherNet Configuration is set the same in
each segment so that the Ethernet segments are terminated properly. If they are
not the same, change the settings as required. Refer to “Configuring the High-
Performance Ethernet I/O Module” within this section.

Repeat Step 2 for each new High-Performance Ethernet I/O Module.

. Test the new High-Performance Ethernet I/O Module. Refer to “Fiber
Backbone Test” within this section.

. Check the traffic statistics. While the backbone test is running, monitor the
module. Refer to “Monitoring Statistics” within this section.

The traffic statistics displayed should report 128 frames per second transmitted
and received on the fiber backbone.

. Check each High-Performance Ethernet I/O Module in the connection. The
traffic statistics displayed should report 128 frames per second received from the
fiber backbone. Additionally, the module should display 128 frames per second
transmitted onto its local Ethernet segment, provided that the segment is
properly terminated. Refer to “Monitoring Statistics” within this section.

. Stop the backbone test on the local I/O module. Refer to “Halt Current Test”
within this section.

. Connect the cables to the port. Once each of the connections has been
established and verified, connect the cables to the appropriate port on each of the
High-Performance Ethernet I/O Modules in the connection and then complete
the following procedure:

* Select one of the High-Performance Ethernet I/O Modules.

» Select Configure from the Tools menu and choose the appropriate port for
that module. Refer to “Configuring the Module” within this section.

Note: If you select the EXT BRIDGE port, you might have to enable the Heartbeat or
SQE parameter for the bridge or other devices connected.

To enable SQE, refer to Table 3-2. If it is not required, select Disabled. You must
disable the heartbeat before you select EXT BRIDGE. Failure to properly select this
parameter may result in loss of data.
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8. Reset the traffic and error counters. Refer to “Resetting Counters” within this
section.

9. Monitor the traffic on the Ethernet segment and the fiber backbone. Refer
to “Monitoring Statistics” within this section.

If the segment has live traffic, the following information is displayed:
* The number of packets received every second for that segment.

* The number of packets transmitted onto the segment every second is also
displayed for other segments connected elsewhere in the system.

* Backbone traffic (receive and transmit) is displayed if any traffic is received
from or transmitted onto the local Ethernet segment.

* If one or more errors display, stop the Monitor display and change the port
type to AUl or Ext Bridge (whichever port is not being used) to avoid
corruption of the Ethernet network.

10. Check for errors on either the backbone or High-Performance Ethernet
segment. Refer to “Displaying Statistics” within this section.

Note: The error display may indicate either “errored” seconds, minutes, and hours, or it
may indicate the total number of errors, depending on whether error reporting is
Sampled or Totaled.

Configuring the Module
This option allows you to select the connection to the Ethernet I/O Module.
1. Click on the High-Performance Ethernet I/O Module from the node view.
2. Select Configure from the Tools menu, or click on the Configure icon.

A screen similar to Figure 3-7 is displayed. Table 3-3 describes the modifiable
fields.
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— High Performance Ethernet Configuration |

850074 Standard|®}

Multi Point |

Encbled |8
Enobled |8
3 Timeslots

| ok | [ Cancel

Figure 3-7. High Performance Ethernet I/O Module
Configuration Screen

Table 3-3. High-Performance Ethernet I/O Module Configuration Parameters

Field

Description

Current Port Type

Allows you to select the port type to use on the module.

To activate the ... Select ...
AUI port AUI

Thin Ethernet port Thinnet coax
MAU port Ext Bridge

CAUTION: If you select Thinnet coax, you must have a
properly-terminated Thin Ethernet Cable already attached to the
port. Failure to do so will result in the interruption of data traffic
through the module. The AUI and the MAU ports may be safely
selected even if there is no cable attached to the ports.

Connection Type

Indicates either a multipoint or point-to-point connection. All modules in
the connection must show the same value in this field.

Multipoint - the module is connected with three or more modules.

Point-to-Point - the module is connected in a connection with only two
modules.

Note: You cannot configure the module for 4-timeslot mode
unless the connection type is set to Point-to-Point. Likewise, you
cannot change the connection type to Multipoint while the module
is in 4-timeslot mode.
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Table 3-3. High-Performance Ethernet I/O Module Configuration Parameters (Continued)

Field Description

Compatibility Mode Allows the High-Performance Ethernet I/O module be fully backward
compatible with prior Ethernet modules.

Note: Select this only when the High-Performance Ethernet
I/0 module must be connected to a connection with earlier
versions.

You cannot modify this parameter when any of the following conditions
occur:

* The module is active (in a connection) and not in a 2-timeslot mode.
* The module is in test mode.

Any attempt to modify this parameter when these conditions occur will
cause an error message.

850038 - The module will configure itself in 2-timeslot mode.
850067 - The module will configure itself in 2-timeslot mode.
850074 Standard - The module can be configured with 1, 2, 3, or 4

timeslots.
Flow Control Enables or disables the flow control mechanism.
SQE Enables or disables the IEEE 802.3-specified SQE or Heartbeat function

for the MAU port. The bridge or other device connected to the port may or
may not require this parameter to be enabled. You must configure this
parameter properly prior to connecting a cable to the MAU port, or data
loss may occur.

Monitoring Statistics
This procedure allows you to monitor traffic on the backbone and the segment. The
transmit and receive frame information and the number of frame errors detected are
continuously displayed and time-stamped for reference.
1. Click on the High-Performance Ethernet I/O module from the node view.
2. Select Monitor from the Tools menu or click on the Monitor icon.
This procedure is identical to the Ethernet I/O module procedure described

earlier in this chapter. Refer to Figure 3-5 for an example and Table 3-2 for an
explanation of the fields.

Resetting Counters

Select Reset Counts from the Ethernet Monitor screen to reset the counts to zero.

3-16



Managing Specific I/O And Link Modules

Performing Tests
The Test option allows you to test a new High-Performance Ethernet network before live
data is sent out onto it. Test traffic can be generated onto the local High-Performance
Ethernet segment or onto the PremNet 5000 fiber backbone.
To initiate an Ethernet test:
1. Select the Ethernet I/O Module as described previously.

2. Select Test from the Tools menu or click on the Test icon.

The system polls the module for the current test status. A Progress box appears
showing the percentage of data read.

3. Select one of the options from the Ethernet Test selection. The choices are:
* Local Segment Test
* Fiber Backbone Test
* No Test
This procedure is identical to the Ethernet I/O Module Test procedure previously

described within this chapter. Refer to “Performing Tests” within the Ethernet I/O
Module section for more detailed information on the specific tests.

Token-Ring 4/16 Mbps 1/0 Module

The Token-Ring 4/16 Mbps I/O Module connects up to eight token-ring devices to the
SNMP PremNet 5000 System.

This section describes how to configure and manage the Token-Ring 4/16 Mbps I/O
module.

Configuration Strategy

The following procedure provides an overall strategy when configuring a new Token-
Ring I/0O module into an existing network. The steps are listed below, after which each
step is explained in detail.

1. Set the I/O data rate to 4 or 16 Mbps. Refer to “Configuring the Module”
within this section.

2. Perform a loop test. This test must pass to continue. Refer to “Loop Test”
within this section.

3. Discontinue the loop test. Refer to “Reset Loop Test” within this section.
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4. Monitor the module connected to the active ring. This determines that this
network is generating proper frame rates with no errors. Refer to “Monitor Ring
Statistics” within this section.

5. Connect the Token-Ring 4/16 Mbps I/O Module to the connection. Refer to
“Configuring Connections” in Chapter 2.

6. Monitor the module just connected to verify proper frame rates. Refer to
“Monitoring Statistics” within this section.

Configuring the Module
This procedure allows you to configure a Token-Ring 4/16-Mbps 1/O Module.
From the node view:
1. Click on the Token-Ring 4/16 Mbps I/O Module.
2. Select Configure from the Tools menu, or click on the Configure icon.

The system displays a screen similar to the one shown in Figure 3-8.

= Token Ring 4f16 Card Configuration

—
Unlocked | |

Unlocked 16 Mbps |
Uniocked [& Locked |13
Unlocked [8 Loopback [

Figure 3-8. Token-Ring 4/16 Mbps I/O Module Configuration Screen
3. Select the correct mode, either 4 Mbps or 16 Mbps.

4. Select the correct RI/RO, either Locked or Unlocked.

Note: Before you change the mode of a module, remove the module from its established
connection. Refer to “Deleting Connections” in Chapter 2. Also, the status must be
Active before changing the mode.
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5. Set the module status to Active or Loopback.

» If you choose Active and the module is in Loopback mode, you are prompted
for a confirmation.

» If you choose Loopback, both the ports and the backplane are looped. This
option allows you to test the module by isolating the network from the
module. While in Loopback, the Token-Ring is disconnected from the
network, allowing you to monitor the integrity of the inserted data.

The Token-Ring should be placed in Loopback mode during initialization of
the network. This allows you to step through the network and verify the

integrity of the system as modules are brought into operation.

To monitor the Token-Ring network for errors, refer to “Monitoring Traffic”
within this section.

6. Choose the port status, either Locked or Unlocked, for all of the ports.

7. Select OK to save the configuration parameters you specified.

Note: If you change the data rate for the module, the following message appears:

WARNING...You have selected a mode change! All other configuration
parameters will be set to default values, and the target module will issue
no response for approximately 10 sec's.

Displaying the Status
This procedure allows you to display the status of the four MAU ports on the module.
From the node view:
1. Click on the Token-Ring 4/16 Mbps I/O Module.
2. Select Status from the Tools menu or click on the Status icon.

The system displays a screen similar to the one shown in Figure 3-9.
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— Card Status

i

—

Figure 3-9. Token-Ring 4/16 Mbps I/O Module Card Status

3. Select OK to return to the node view.

Monitoring Traffic

You can monitor the frames and errors appearing on the module. The frames and errors
are continuously displayed and time-stamped for reference.

From the node view:
1. Click on the Token-Ring 4/16 Mbps I/O Module.
2. Select Monitor from the Tools menu or click on the Monitor icon.

The system displays the monitor screen, as shown in Figure 3-10.
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= Token Ring Monitor

10:03:22 26-Mar-95
8:12:07 27-Mar-95

Figure 3-10. Token Ring Monitor

The screen displays the times when the maximum and minimum number of
frames occurred, the maximum and minimum counts for frames and errors, and
the time when the maximum number of errors occurred.

3. Select Node from the View menu or click on the Node icon to redisplay the
previous screen.

Resetting Counters

You can reset the counts to zero by selecting Reset Counts while displaying the Token-
Ring 4/16 Mbps I/O Module Monitor screen.
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Performing Tests
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The following procedures allow you to test the Token-Ring 4-16 Mbps I/O Module
before connecting the module into an active ring.

1. Display the Node view and click on the Token-Ring 4/16 Mbps I/O Module.
2. Select Test from the Tools menu or click on the Test icon.
The system polls the module for the current test status (refer to Figure 3-11).
The applicable Token-Ring 4/16 Mbps /O Module tests include:
* Loop Test
* MAU/Cable

¢ Reset Test

= Token Ring Test |

——

Figure 3-11. Token Ring Test

Note: These tests are interruptive and will disrupt the normal data flow on the
associated unit(s).

Loop Test

The loop test generates an abort frame, which is transmitted through the established ring.
The established ring may be either a single I/O module or a multi-point ring. In either
case, the loop test places all /O modules on the ring into loopback, with all ports locked
out.

Perform a loop test before connecting the module into an active ring.
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From the node view:

1. Click on the Token-Ring 4/16 Mbps 1I/O Module.

2. Select Test from the Tools menu or click on the Test icon.
Each Token-Ring 4/16 Mbps I/O Module, in sequence, monitors the incoming
abort frames. If the incoming signal is free of errors, the signal is passed to the
next module in the ring. If errors are detected, the module notifies the system
(with an alarm message) and the test initiation signal is not transmitted to the
next module, allowing you to isolate a defective I/O module.
To identify the defective I/O module, complete the following steps:
a. As the test continues to run, access each I/O module in the connection.
b. View any alarms by selecting Alarms from the Tools menu, or click on the

Alarms icon. You can determine the defective I/O module from the alarm

messages displayed.

c. Remove the I/0 module from the connection, and the test continues.

Note: Occasionally, a downstream I/O module transmits errors that cause the upstream
I/0 module to alarm. Contact your System Administrator to determine whether this is
the case.

When the abort sequence is received by the initiating I/O module, each I/O
module's MAU ports are tested. The incoming abort frames are copied,
transmitted through the MAU ports, and compared with the original incoming
signal, using two separate frame counts. The frame counts must be equal (+5
counts) to pass the test.

To monitor the frame counter, choose Monitor from the Tools menu or click on
the Monitor icon.

» If the frame counts match, the signal is passed to the next I/O module in the
ring.

* If the frame counts do not match, the I/O module responds with an alarm
message and the signal is not retransmitted. The frames and errors displayed
should be almost identical.

Note: When the module is in Loop Test, the values under the Frames/Second field
represent the number of abort frames sent out and the values under the Errors/Second
field represent the number of abort frames received.
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Reset Loop Test
The loop test continues to run until you select Reset Test from the Token-Ring Test
menu. You may also view the delay time for the ring. Use the delay time to verify that

the estimated ring-delay time is accurate. (The estimated ring-delay time is derived by
adding up the delay times of each network component.)

Mau/Cable Test
To test the cables connected to the RI/RO ports on a Token-Ring 4/16 Mbps I/O Module:

¢ Select MAU/Cable.

Note: An active Token-Ring signal must be present in the system before you can run
this test. The Token-Ring 4/16 Mbps I/O module must also be in loopback. During the
test, the MAU ports are locked out.

Token-Ring 4 Mbps I/O Module

The Token-Ring 4 Mbps I/O Module connects up to eight token-ring devices to the
SNMP PremNet 5000 System.

This section describes how to configure and manage the Token-Ring 4/16 Mbps 1/O
Module.

Configuring the Module
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This procedure allows you to configure a Token-Ring 4 Mbps I/O Module.
From the node view:

1. Click on the Token-Ring 4 Mbps 1/O Module.

2. Select Configure from the Tools menu, or click on the Configure icon.

The system displays a screen similar to the one shown in Figure 3-12.
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= Token Ring 4Meq Card Configuration

—
—

Locked |8 Locked &
Locked |8 Locked [
Locked [ Locked &
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Figure 3-12. Token-Ring 4 Mbps I/O Module Configuration Screen
3. Choose the RI/RO status, either Open or Locked.
4. Choose the port status, either Locked or Unlocked, for all of the ports.
5. Select OK to save the configuration.

Refer to “Token-Ring 4/16 Mbps I/O Module” in the previous section for information on
the following:

* Displaying the Status

* Monitoring Traffic
e Performing Tests

RS-232 4-Port I/0 Module

The RS-232 4-Port Multi-Drop I/O Module offers asynchronous and synchronous data
communication via four RS-232 interface ports at speeds up to 38.4 Kbps. The module
can also be configured to provide multidrop functionality. You can configure each port
on the module independently.

This section describes how to configure and manage the RS-232 4-Port I/O Module.

Configuring the Module

This procedure allows you to set the module's port clocking and port loopback, and to
control the module's DTR, RTS, BSY, UNA, DSR, DCD, CTS, and RI signals.
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From the node view of the RS-232 4-Port I/0 Module:

1. Click on the RS-232 port you want to configure. The port highlights by

changing to a darker gray.

2. Select Configure from the Tools menu or click on the Configure icon.

Figure 3-13 is displayed, which allows you to change the configuration.

= R5-232 Port Configuration |

3.

—
Siave to DTR ] " Cancel |

Slave to RTS  [#
Slave to BSY |_ Hon-Standard |_

Stave to UNA_ |8 ECTTa
Stave to Fift) |8
Stave to Fif1) |8
Stave to Fi(3) |8
Stave to Fil4) |8

Figure 3-13. RS-232 Port Configuration

Select the type of setup, either Multidrop Central, Multidrop Remote, Non-
Standard, or Factory Default.

Note: If you select either Multidrop Central or Multidrop Remote, the Signal Controls are
automatically assigned.

4.

6.

7.

Select the Clock Mode of the port.
Select the Loopback Control, either ON or OFF.

Enable or Disable the Streaming Threshold. Enter zero to disable it. Enter a
value from 1 to 40 to enable and set the threshold level.

Enable or Disable Receiver Enabling.
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9. Select the appropriate Signal Controls. Each interface signal can be slaved to
another signal, or tied to a mark or space level.

10. Select OK to accept the changes.

Monitoring the Status
This procedure allows you to monitor the activity of the control lines.

From the node view of the RS-232 4-Port I/O Module, or from the port level connection
view:

1. Select Monitor from the Tools menu, or click on the Monitor icon.

The Time, Port, DTR, RTS, BSY, UNA, DCD, CTS, DSR, and RI signals
received by the module are displayed.

2. Press [ESC] to redisplay the previous screen.

RS-422 I/0 Module

The RS-422 /O Module offers asynchronous and synchronous data communication
through four DB-25 connectors. The maximum data rate for asynchronous mode is 256
Kbps, and the maximum data rate for synchronous mode is 2.048 Mbps. You can
configure each port on the module independently.

This section describes how to configure and manage the RS-422 I/O Module.

Configuring the Module

This procedure allows you to configure each port of the RS-422 in either the DTE or
DCE mode.

Display the node view and select the module. Select the port to configure by clicking on
it. The port changes color to a darker gray.

1. Select Configure from the Tools menu or click on the Configure icon.
The RS-422 Port Configuration screen appears. There are two configuration
screens, one for a DTE setting and the other for DCE setting. This depends on

the default configuration of the module (refer to Figure 3-14).

2. Select the Data Direction desired (DTE or DCE) from the RS-422 Port
Configuration screen.
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Note: If DTE is in the data direction field, the DCE fields are grayed out. If DCE is in
the data direction field, the DTE fields are grayed out.

3. Click on OK to set the data direction of the port.
4. Click on the port again to finish the configuration.

5. Select Configure from the Tools menu or click on the Configure icon. The
correct fields appear on the screen.

Configuring the Port for DTE

= R5-422 Port Configuration

BiE_|Io Sove [ B

DCE Mode Only (& Slave to CTS |_
DCE Mode Only Slave to DSR  [[#
DCE Mode Only (&

Slave to DCD  [[#

DCE Mode Only [f}{DCE Mode Only [ Slave to FI0) [#fl0-3ms [®
DCE Mode Only [ Slave to FI(1)  [#fl0-3ms [®
DCE Mode Only |5

= [ ok ][ Cancel

DCE Mode Only
DCE Mode Only |

Figure 3-14. RS-422 Port Configuration (DTE)

1. Select the Clock Mode and the DDS Mode from the General Controls section of
the screen (refer to Table 3-4).

2. Configure the DTE Signal Controls.
3. Select Copy To if you want to send the same configuration to another port.

4. Select OK to save the configuration.
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Configuring the Port for DCE

Refer to Figure 3-15.

= R5-422 Port Configuration

Stave [

Slave to HTS |_ DTE Mode Only |&
Slave to DTH |_ DTE Mode Only |
DCE Mode Only |_ DTE Mode Only |&
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Slave to FI(1) [®}{0-3ms [® DTE Mode Only [El{DTE Mode Only [
Slave to FI)_[8][03me 8

= ok || _cancel

Figure 3-15. RS-422 Port Configuration (DCE)

1. Select the Clock Mode and the DDS Mode from the General Controls section of
the screen (refer to Table 3-4).

Note: In the DCE mode of operation, DDS must be set to NO.

2. Configure the DCE Signal Controls (refer to Table 3-4).
3. Select Copy To if you want to send the same configuration to another port.

4. Select OK to save the configuration.
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Table 3-4. RS-422/V.35 Configuration Fields

Field

Description

Data Direction

DTE or DCE

Clock Mode Async, Slave, Ext Sync, 56K to 1024K
DDS Digital Data Service (Yes or No). Applies to DTE
mode only.
DTE Signal Controls Fiber Out 0, Fiber Out 1, and Fiber Out 2 are EIA
Fiber Out 0 signals renamed because they are transmitted out
Fiber Out 1 through the fiber backbone. The selections are
Fiber Out 2 Space, Mark, Slave to CTS, Slave to DSR, Slave to
DCD, DTE Mode Only.
Example: Setting Fiber Out (0) to Slave to CTS
means that CTS is now called Fiber Out (0) because
it is going out the fiber backbone.
Fiber In O Fiber In 0, Fiber In 1, and Fiber In 2 are EIA Signals
Fiber In 1 renamed because they are received in through the
Fiber In 2 fiber backbone.
Request to Send (RTS) The selections for these fields are Slave to FI(0),

Data Terminal Ready (DTR)

Slave to FI(1), Slave to FI(2), Slave to CTS, Slave to
DSR, Slave to DCD, and DTE Mode Only.

DCE Signal Controls Fiber Out 0, Fiber Out 1, and Fiber Out 2 are EIA
Fiber Out 0 signals renamed because they are transmitted out
Fiber Out 1 through the fiber backbone. The selections are
Fiber Out 2 Space, Mark, Slave to RTS, Slave to DTR, Slave to
UNA (V.35), and DCE Mode Only.
Example: Setting Fiber Out (0) to Slave to RTS
means that RTS is now called Fiber Out (0) because
it is going out the fiber backbone.
Clear to Send (CTYS) The selections for these fields are Space, Mark, Slave
Data Set Ready (DSR) to FI(0), Slave to FI(1), Slave to FI(2), Slave to RTS,

Data Carrier Detect (DCD)

Slave to DTR, Slave to UNA (V.35), and DCE Mode
Only.

Delays

Selectable delays in milliseconds for the EIA signals
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V.35 4-Port I/ O Module

The V.35 4-Port I/0O Module offers asynchronous and synchronous data communication
through four V.35 interface ports. The maximum data rate for asynchronous mode is
256 Kbps and the maximum data rate for synchronous mode is 2.048 Mbps. You can
configure each port on the module independently.

This section describes how to configure and manage a V.35 4-Port I/O Module.

Configuring the Module

This procedure allows you to configure each port of the V.35 in either the DTE or DCE
mode.

Display the node view and select the module. Select the port to configure by clicking on
it. The port changes color to a darker gray.

1. Select Configure from the Tools menu or click on the Configure icon.

The V.35 Port Configuration screen appears. There are two configuration
screens, one for a DCE setting and the other for DTE setting. This depends on
the previous configuration of the module (refer to Figure 3-16).

2. Select Data Direction from the V.35 Port Configuration screen.

Note: If DTE is selected in the data direction field, the DCE fields are grayed out. If
DCE is selected in the data direction field, the DTE fields are grayed out.
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Configuring the Port for DTE

= ¥.35 Port Configuration

Async & 3]

Slave to CTS &)
Slave to DSR  [&)
DCE Mode Only [ Slave to DCD  [&)

DCE Mode Only [Fl{ DCE Mode Only [ Slave to FI[0) [#fl0-3me [
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DCE Mode Only [Fl{ DCE Mode Only [ Slave to FI[2) [#fl0-3me [

| ok | [ Cancel

Figure 3-16. V.35 Port Configuration (DTE)

1. Select the Clock Mode and the DDS Mode from the General Controls section of
the screen (refer to Table 3-4).

2. Configure the DTE Signal Controls (refer to Table 3-4).
3. Select Copy To if you want to send the same configuration to another port.

4. Select OK to save the configuration.
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Configuring the Port for DCE

Refer to Figure 3-17.

= ¥.35 Port Configuration
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Figure 3-17. V.35 Port Configuration (DCE)

1. Select the Clock Mode and the DDS Mode from the General Controls section of
the screen (refer to Table 3-4).

Note: In the DCE mode of operation, DDS must be set to NO.

2. Configure the DCE Signal Controls (refer to Table 3-4).
3. Select Copy To if you want to send the same configuration to another port.

4. Select OK to save the configuration.
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4-Wire Voice 1/0 Module

The 4-Wire Voice I/O Module provides bidirectional transport of voice or voiceband
data circuits (300 to 3400 kHz) to another 4-Wire Voice I/O Module in a PremNet 5000
connection.

There are three versions of the 4-Wire Voice I/O module:
* Ear and Mouth (E&M)
* Push-To-Talk (PTT)
* Runway Visual Range (RVR)

These versions support a variety of user applications.

This section describes how to configure and manage the 4-Wire Voice I/O Module.

Configuring the Module
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This procedure enables you to assign voice channels to specific ports on the I/O module.
You can assign any of the 32 channels to any of the physical ports on the I/O module.
To create a point-to-point voice circuit, assign the same channel to each of the two ports.
For multiple voice channel drops, assign the same to each physical port on each I/O
module that you want to participate in the voice circuit.

Configuring a 4-Wire Voice Card at the Port Level
To configure a 4-Wire Voice I/O module at the port level:
1. Display the node view.
2. Select a port by clicking on the port you want to configure.
3. Select Configure from the Tools menu or click on the Configure icon.

The port level connection view of the selected module is displayed (refer to
Figure 3-18).
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= 4-%¥ire Port Configuration |

R
e |8

Figure 3-18. 4-Wire Port Configuration
4. Enter a channel number, 1 to 32, in the Connect Channel Field.
5. Select the Mouth setting (Free, FO, or F1).

» If Free, the electrical signal is transmitted at the non-active (0) or the active
(1) state, depending on the state of the electrical signal that is transmitted by
the attached external equipment.

» If FO, the electrical signal will be forced to a non-active state.
» If F1, the electrical signal will be forced to an active state.
6. Type the value for the RX Gain Signal and the TX Gain Signal.

* RX Gain is added to the Pulse Code Modulation (PCM) signal before it is
output to the line.

* TX Gain is added to the line signal before it is digitized and sent to the PCM
channel. The 4-Wire Voice I/O module uses the PCM encoding method of
conversion, which uses 0 dBm or 1 milliwatt as its reference. These are the
factory-set defaults.

With 0 dBm as the reference, the 4-Wire Voice I/O Module has a dynamic
range of +2.5 dBm to -23 dBm, and can receive and transmit signals within
this range without distortion. If the external attached equipment produces a
signal with a signal level that is outside these parameters, you may need to
adjust the system gain on the data port.
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Note: The RX and TX Reference Signal field values are factory-set defaults and provide
a 0.0-dBm reference of 1 milliwatt. Each number increment represents 0.1 dB. To
maintain this relative calibration, do not change the reference number.

7. Select the law companding method (u-Law, A Law EBI, A Law Not EBI).
Companding is the process of compressing analog signals for digital
transmission and decompressing digital signals for transmission to the attached
analog equipment. p-Law is the standard companding method used in the

United States. A-law is the standard companding method used in Europe.

* Select A-not even bit inv to set the active companding method to A-law with
no Even Bit Inversion.

* Select p-Law to set the active companding method to p-Law.

* Select A-even bit inv to set the active companding method to A-law, including
Even Bit Inversion.

8. Select OK to save the configuration.

Video I/0 Module

Video I/0 Modules enable you to communicate video/audio information from a central
site to groups of users at remote sites. The Video I/O Modules come in three types: 2-
Way Video, 1-Way Video Input, and 1-Way Video Output. This section covers all three

types.

Configuration Strategy
This procedure provides the steps necessary to establish Video I/O connections.
1. Verify bandwidth requirements. Refer to “Configuring the Module” within
this section to select the bandwidth required by the application. The default

setting is six time slots (compression 12:1).

2. Set up the Video I/O Module for the application configuration. Refer to
“Configuring the Module” within this section.

Configuring the Module
To configure any of the Video I/O Modules:

1. Display the node view and click on the Video I/O Module.
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2. Select Configure from the Tools menu, or click on the Configure icon.

The Video Configuration screen appears (refer to Figure 3-19). Table 3-5
describes the modifiable parameters.

= Z¥ay Yideo Configuration

Figure 3-19. 2 Way Video I/0 Module Configuration Screen
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Table 3-5. Configure Video I/O Module Parameters

Field Description

Timeslots Select the number of time slots: 2, 4, 6, or 8. The default time slot setting of
six provides enough bandwidth to produce quality images.

Standard Select the video standard displayed on the screen. Select (NTSC) National
Television Systems Committee (US), or (PAL) Phase Alternative Line
(Europe).

GENLock Enable the external GEN clock that is used to synchronize video, or use the
internal clock.

Display Select color or black and white. Set according to what the input source
transmits.

Audio Input Select the input port that will be used to receive sound. These ports are
standard Y-inch stereo audio jacks.

Mute Enable or disable the audio signal received from the fiber and transmitted to
the audio out port.

Audio Sample Select either 8-bit companded or 16-bit companded.

Baud Rate Select a baud rate (300, 1200, 2400, 4800, or 9600).

Parity Select parity (None, Odd, or Even).

# of Bits Select either a 7 bit or 8 bit format.

Audio Loopback Allows you to check and adjust audio signals before setting connections. If
enabled, the audio IN port is logically connected to the audio Out port.

Module Reset Allows you to reset the module if you experience freeze-frame in the video.

Passthru State

Select ON or OFF to configure the video application for multipoint.

Broadcasting

Select ON or OFF to configure a broadcast session. This option does not
apply to 1-Way Video Output.

T1/E1 1/0 Module
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T1 and E1 are used to differentiate between North American (T1) and European (E1)
hierarchical voice/data transmission systems used in the digital telephone network.

The physical module will be a DS1, a DS1A, or a G.703. Configuration and
management of all three modules is the same.

This section describes how to manage and configure the T1/E1 I/O Module.
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Configuring the Module

This procedure allows you to configure the T1/E1 I/O Module thresholds, error
detection/source, loopback mode, and cable length.

To configure the module:

1. Display the node view and select the port to configure by clicking on it. The
port changes color to a darker gray.

2. Select Configure from the Tools menu, or click on the Configure icon.

The T1/E1 I/O configuration screen is displayed (refer to Figure 3-20). The
Bipolar Pulse Violation Error per second (BPVE/sec) threshold field is

highlighted.

Note: BPV is a bipolar pulse with the same polarity as the preceding pulse. This is a
violation of the Alternate Mark Inversion rule.

= D51 Port Configuration

32000
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None |8
vo  |®
T

| ok || Cancel

Figure 3-20. DS1 Port Configuration

3. Enter a number between 1 and 32000 for the BPVE threshold limit. An alarm
occurs when this limit for BPVE/sec. is exceeded.

4. Select the Error Detection Algorithm, either B8ZS or AMI, for the bipolar
violation error detector on the port.
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Note: This must match the type of bipolar signal being transported, or errors will be
reported. (However, failure to properly select this option will not cause errors to be
induced in the actual transported signal.)

5. Select the error detect source, either Remote or Local.
6. Select the loopback mode, either Remote or Local.
* Remote allows you to place a far-end port in a loopback state such that it will
return data to the near end. When invoked, input and output LEDs on the

T1/E1 module flash continuously.

* Local loops TX data locally and appears at the local RX port on the
connector. When invoked, input and output LEDs on the T1/E1 module flash
continuously.

7. Select either YES or NO for Tx All 1s on LOS.

8. Select the Cable Length (0-133ft, 133-266ft, 266-399ft, 399-553ft or 533-655 ft).

9. Select OK to accept the configuration.

Monitoring the Status
This procedure allows you to monitor Bipolar Violation Errors (BPVE) relative to
realtime, and displays the calculated error-free seconds (EFS) and elapsed time (ET)

since the last reset occurred.

To monitor the status:

—_—

. Display the node view and click on the T1/E1 I/O module.

[\

. Select a port by clicking on it. The port will change color to a darker gray.
3. Select Monitor from the Tools menu or click on the Monitor icon.

The Time, Port Elapsed Time, and Bipolar Violations signals received by the
T1/E1 I/O module are displayed.

4. Select Reset Counts to reset the counts.

The message is displayed: “Are you certain? Press Y to confirm. Any other key
to cancel”.

5. Select Cancel to return to the previous screen.
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Performing Tests

This operation allows you to perform a complete self test of the established TX and RX
circuit paths for the near-end and far-end modules.

Note: The port at the remote end must be looped back before this test can run.

To initiate a test:

1.

2.

3.

Display the front view of the T1/E1 I/O Module:
Select a port by clicking on the desired port.
Select Tools/Test from the menu, or click on the Test icon.

The message is displayed: “The port at the remote end must be looped back for
this test”.

. Select OK to continue.

A pattern is generated at the near end and is sent to the far end, where it is
looped back to the near end and analyzed for error content. When the test is
complete, the results are displayed (whether the test passed or failed and whether
there were any data or BPV errors).

3270 8/32-Port I/0 Module

The 3270 8/32-Port I/O Module enables you to connect 3270 devices to the PremNet
5000 System. 3270 refers to a series of similar interfaces that are common to the 3x7x-
series physical and electrical interface protocols.

This section describes how to configure and manage the IBM 3270 8/32-Port 1/0
Module.

Configuring the Module

To set the 3270 8/32-Port I/O Module's mode to control the terminal, 3274 Controller,
3174 Controller, Mux with 3299, and Mux without 3299:

1.

Display the node view and click on the 3270 8/32-Port I/O Module.

2. Select Configure from the Tools menu or click on the Configure icon.

The card configuration screen is displayed (refer to Figure 3-21). This screen
applies to both the 8-Port and 32-Port modules. The Port Configuration screens
follow.
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= 3270 Card Configuration
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Figure 3-21. 3270 Card Configuration Screen

3. Select one of the following from the 3270 Mode field:

* 3274

» 3271

* Mux with 3299

* Mux w/o 3299

e Terminal
4. Select each of the four Receiver Bias fields and choose Enable or Disable.
5. Select each of the four Logical Group fields and choose Enable or Disable.

6. Click on OK to accept the card configuration.

The port configuration for the 8 Port card and the 32 Port cards are slightly
different.

Establishing Port Connections

8-Port Card
1. Click on the port you want to configure.

2. Select Configure from the Tools menu or click on the Configure icon. The port
configuration screen appears (refer to Figure 3-22).
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= 3270 Port Configuration
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Figure 3-22. 3270 Port Configuration
3. Select the Port Enable field and choose Enable or Disable.
4. Select the Port Polarity field and choose Normal or Reversed.
5. Select the Transmit Delay field and choose Cleared or Set.
6. Select the Revr Fast Check field and choose Cleared or Set.
7. Select the Logical Channel field and enter a channel number between 1 and 32.

8. Select OK to save the configuration.

32-Port Card
1. Click on the port section you want to configure, either 1-16 or 17-32.
2. Select Configure from the Tools menu or click on the Configure icon. The port
configuration screen for your selected section appears. This screen reappears

after each port configuration. Select Cancel when port configuration is
complete. Refer to Figure 3-23 for port selection.
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— Select Port 1-16 |

Figure 3-23. Port Selection
3. Click on the port you want to configure.

4. Select OK to bring up the port configuration screen. Refer to Figure 3-22, Port
Configuration.

5250 8-Port and 4-Port I/0 Modules

The 5250 I/O Module transports the 5250 serial bit stream from an AS/400 across the
fiber backbone using one TDM time slot.

This section describes how to configure and manage the 5250 8-Port and 4-Port I/O
Modules.

Configuration Strategy

The following procedure provides an overall strategy when configuring a new 5250
8-Port/4-Port I/O Module into an existing network. Review the steps carefully. Each
step is broken down into a more detailed procedure.

1. Configure the interface type. Refer to “Configuring the Module” within this
section.

2. Establish a connection. Refer to “Configuring Connections” in Chapter 2 for
more detail.

3. Establish port-level connection between the controller module and the
peripheral modules. Refer to “Enabling/Disabling All Ports” within this
section.

4. Enable the ports. Refer to “Changing the Port Configuration” within this

section.
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Configuring the Module

To change the module type:

1. Display the node view and click on the 5250 I/O Module.

2. Select Configure from the Tools menu or click on the Configure icon. The 5250
Card Configuration screen appears (refer to Figure 3-24).

= 5250 Card Configuration |

Peripheral |_

Do Not e
Do Not e

| ok || cancel

Figure 3-24. 5250 Card Configuration

3. Select the Module Type field and choose Controller, Peripheral or Mux.

Depending on the module type selected, the module will operate in a different
manner:

Select Peripheral if the connecting workstations or peripheral devices are in a
daisy-chain configuration. Each port will extend the controller’s port,
allowing the same seven devices to be connected in series.

Each peripheral module in the connection compares the port address of the
received backplane data with its port map connection (see “Establishing Port
Connections” within this section).

If the address compares, the data is received off the backplane and processed
to the interface. In all cases, the data received from the backplane is
retransmitted onto the backplane in the next available time slot (loop
through). The Controller module prevents data from circulating
unnecessarily.

Select Mux to allow direct connection of workstations to the individual ports.
Each port will support one workstation or peripheral device.
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¢ Select Controller to allow the module to connect to the AS400 workstation
controller.

Note: All ports on the controller module must be physically connected to the same
AS400 Controller. Separate controllers cannot share the same module.
Only one controller module is allowed in the same connection.

4. Select the Connections field and choose Do Not Reset or Reset.
5. Select the Reset Count field and choose Do Not Reset or Reset.

6. Select OK to save the configuration.

Establishing Port Connections
The modules maintain a port-level connection (port 1 to port 1, port 2 to port 2, etc.).
This procedure allows you to determine which ports on the controller module are going

to be connected at the different peripheral modules.

1. Click on the port you want to configure. The Port Configuration screen appears,
as shown in Figure 3-25.

2. Select the Port Lockout field and choose Enable or Disable.
3. Select the Port Connection field and choose Add or Delete.
4. Select OK to save the configuration.

Repeat steps 1 through 4 for each additional port to configure.

= 5250 Port Configuration

Disabled |8
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Figure 3-25. Establishing Port Connections
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Note: If you are displaying a 5250 4-Port I/O Module, only Ports 1-4 are available to
add or delete the connection.

Reset Rx Frame Synchronization
To reset the Rx frame synchronization error count:
1. Display the node view and click on the 5250 I/O Module.

2. Select Configure from the Tools menu or click on the Configure icon. The card
configuration screen appears (refer to Figure 3-24, 5250 Card Configuration).

3. Select the Reset Count field and choose Reset.

ATM I/O Module

The Asynchronous Transfer Mode (ATM) I/O Module enables you to send and receive
short, fixed-length packets called “cells” using the ATM transport.

This section describes how to configure and manage the ATM 1/O Module.

Configuration Strategy

This procedure outlines the steps to establish ATM connections. The steps are listed
below, after which each step is explained in detail.

1. Configure the ATM Module. Refer to “Configuring the Module Settings”
within this section to define the number of time slots and cell-shaping
parameters.

2. Configure the Virtual Paths. Refer to “Configuring the Virtual Path” within
this section to add or delete ATM Virtual Paths.

Note: Once the connections have been assigned, you cannot change the Module’s
bandwidth without deleting the connection.

Note: Disable the Loopback before establishing a connection.

Configuring the Module Settings

This procedure describes how to specify the following module settings:
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* The UNI interface type, DS3 (45 Mbps) or Fiber (100 Mbps). This option is
applicable to the 850082 module only.

¢ The number of time slots.

* The module’s power setting, line length, and enable/disable the cell payload
scrambler (DS3 only).

* The cell-shaping percentage for the ATM network.
To configure the module settings:
1. Display the node view and click on the ATM I/O Module.
2. Select Configure from the Tools menu, or click on the Configure icon.

The ATM Configurators screen appears (refer to Figure 3-26).

= ATM Configurators |

Figure 3-26. ATM Configurators
3. Select Do Card Configuration from the ATM Configurators screen.

The ATM Interface Configuration screen appears (refer to Figure 3-27).
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= ATM Interface Configuration |

CEEN

Figure 3-27. ATM Interface Configuration

4. Click on each field of the screen and enter the appropriate settings (refer to
Table 3-6).
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Table 3-6. Configuration Modifiable Parameters

Parameter Description
Time Slots Allows you to allocate time slots to the ATM I/O Module. This option is
available only in Standby mode.
Note: Changing the time slots causes the module to momentarily lose
communication with the Network Management Module (NMM).
Interface Type Specify the UNI interface type, DS3 (45 Mbps) or Fiber (100 Mbps). This
option is applicable to the 850082 module only.
Tx Clock Source Specify whether the Tx clock for the module is externally or internally
sourced.
Cell Shaping Allows you to allocate link bandwidth to the module. For example, on the

Fiber Tx interface, which operates at 100 Mbps, you can specify cell-rate
shaping on the ATM 1/0 module for up to a maximum of 34.5% of the
bandwidth used for non-idle cells. This means that the active cell rate
leaving the ATM I/O Module port would always be less than or equal to
34.5 Mbps.

DS3 Line Length

Specify whether you are using a short cable (less than 225 feet) or a long
cable (more than 225 feet) for the DS3 connectors.

LIU Power Select either a high or low power setting for LIU (Link Interface Unit) ATM
Modules.

Cell Payload Scrambler Allows you to select whether or not to use the payload scrambler. This is
available in DS3 mode only.

Loopback Mode Allows you to perform loopback testing on either the ports or the backplane
of the current ATM Module.

Obtain Remote VPIs Allows you to query the network for connections to the local ATM Module.

5. Select OK to save the configuration.

Configuring the Virtual Path

To configure the virtual path:

1. Display the node view and click on the ATM 1/O Module.

Note: This module is the local ATM Module.

2. Select Configure from the Tools menu or click on the Configure icon.
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= ATM Configurators |

Figure 3-28. ATM Configurators

3. Select Do Virtual Path Configuration from the ATM Configurators screen. The
Virtual Path Configuration screen appears (refer to Figure 3-29).

¥irtual Path Configuration

0 |
01 04 07
0 |

| pad || Cancet

Figure 3-29. Virtual Path Configuration

Adding a Virtual Path

1. Select Add VPI. The Add VPI, Delete VPI, View Table, and Cancel fields gray
out, and the Add Virtual Path section highlights (refer to Figure 3-30).
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¥irtual Path Configuration

| pasvir | [ potore 99 | | Vien sotle | | farcel

01 04 04
01 04 07

[
| Add | | Cancel

Figure 3-30. Virtual Path Configuration (ATM Modules)

2. Enter a number between 1 and 256 in the Local VPI field. This number is
arbitrary. Its function is to keep track of which module is which, local or
remote.

3. Enter a different number between 1 and 256 in the Remote VPI field. This
number is arbitrary. Its function is to keep track of which module is which, local
or remote.

4. Highlight Remote ATM Module from the list in the field.

5. Select Add to save the Virtual Path.

6. Select View Table to see a list of the Virtual Paths.

7. Select Cancel to return to the Node View.

Deleting a Virtual Path
1. Select View Table to see the existing virtual paths.
2. Highlight a virtual path to delete.
3. Select Delete VPI to delete the virtual path.

4. Select Cancel to return to the Node View.
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SONET/SDH Link Module

The SONET/SDH (OC3) Link Module converts PremNet backplane data into SONET or
SDH frames (mode is software-selectable), which are transmitted at 155 Mbps over fiber
optic cable.

Note: SONET is an acronym for Synchronous Optical Network. SDH stands for
Synchronous Digital Hierarchy.

Configuration Strategy

This procedure describes how to configure and manage the SONET/SDH link module.
Review the steps carefully. The steps are listed below, after which each step is explained
in detail.

1.

Select the target link module. Refer to “Displaying the SNMP PremNet I/O
and Link Module” within this chapter.

Set the link module to the desired operating mode. Select either SONET
(United States) or SDH (Europe). Refer to “Configuring the Module” within
this section.

Select the type of ring topology for your network. Configure the link to
single-link (one link per node) or counter-rotating links (two links per node).
Refer to “Configuring the Module” within this section.

Initialize unused overhead bytes. Refer to “Configuring the Module” within
this section.

Select the timing clocks for the target link module. Specify/change the timing
clock source for the link module. Refer to “Configuring the Module” within this
section.

Configuring the Module

To configure the SONET/SDH Link Module:

1.

Display the node view and click on the SONET/SDH Link Module.

2. Select Configure from the Tools menu or click on the Configure icon. The OC3

SONET/SDH Link Configuration screen is displayed (refer to Figure 3-31).
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— 0C3 SONET!SDH Link Configuration

SONET 3
Master=Internal/Slave=Line |_

Figure 3-31. OC3 SONET/SDH Link Configuration
3. Select the Mode field and choose either SONET (US) or SDH (Europe).

4. Select the Timing Control field and choose one of the following:

* Master=Internal/Slave=Line - The appropriate transmit clock is automatically
selected.

e Line Timing - The transmit SONET/SDH clock source is the clock recovered
from the received signal.

¢ Internal Clock - The transmit SONET/SDH clock source is the module’s
internal 20 ppm oscillator.

* BITS Clock (SONET only) - The transmit SONET clock source is the clock
recovered from the BITS clock input. This option is not displayed if the link
module is set to SDH mode.

If you select the BITS clock, the new timing mode becomes effective
immediately.

5. Select the Ring Mode field and choose Single or Counter/Rotating.

Note: Single-link configurations do not support protection switching or the Bellcore
performance monitoring requirements.
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In a PremNet node that has two link modules installed (either in Slots A-B or in C-D), do
not attempt to configure one or both links on a single-link ring. This is not a valid
configuration and may cause system problems.

6. Select the Overhead Init Value field and choose 0 or FF.

Overhead Initialization Value - This option allows you to “stuff” the SONET
overhead bytes that are not used by the link module. According to Bellcore
specifications, these bytes must be filled with either zeros (0s) or ones
(hexadecimal Fs).

7. Select the Terminal Loopback field and choose ON or OFF. Terminal Loopback
loops the signal from transmit port to receive port on the selected Link Module.
This tests the local SONET/SDH data path and associated hardware.

8. Select the Facility Loopback field and choose ON or OFF. Facility Loopback is
run between two link modules. The signal goes from Tx on module one to Rx

on module two, and back again from Tx on module two to Rx on module one.

9. Select OK to save the configuration.

T3 Link Module

Configuration
To configure the T3 Link Module:
1. Display the node view and click on the T3 Link Module.
2. Select Configure from the Tools menu or click on the Configure icon. The T3

Link Configuration screen is displayed (refer to Figure 3-32). The Line Build
Out field is highlighted.
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= T3 Link Configuration

Cable < 225" |-
Low Power |8
Internal Clock |_

Counter Rotaing®

Figure 3-32. T3 Link Configuration

. Select the appropriate cable length.

Cable < 225°
Cable > 225°

. Select the appropriate Power Output level. Normally this selection is low.

Select High Power if the cable length is greater than 225 feet.

. Select the appropriate Timing Control from the following:

Auto/Master Internal/Slave Recovered - is the default clock source. The
module selects the clock, either Internal or Recovered, automatically.
Internal Clock - is the module’s internal 44.736 MHz clock.

Recovered clock - is the clock recovered from the received signal.

. Select the appropriate Ring Mode, either Single or Counter Rotating.

. Select the appropriate Terminal Loopback state, either ON or OFF.

The terminal loopback test loops data from the Switch module through the T3
and back to the Switch module. This tests all the T3 Link module except the
physical interface.

. Select the appropriate Facility Loopback state, either ON or OFF.

The facility loopback test connects the incoming T3 received signal to the T3
transmitter in the return direction. This loopback requires at least two T3 Link
Modules.

. Select OK when you are finished with the configuration.



Chapter 4
Reports

Introduction

There are two types of reports:

* Network Revision Report

* Nodal Configuration Report

Network Revision Report

The Network Revision Report displays a list of cards and their locations, based on the
selected criteria. It is used, for example, when the operator wants to know which
ENMM cards have a software revision earlier than Rev. 3.5. The user enters this range.
The application searches the network and reports the location of all the appropriate
ENMM cards. The report displays a list by Ring, Node, and Position.

Generating a Network Revision Report

1.

2.

6.

Select Reports from the Tools menu.

Select Network from the Reports menu.

. Enter the criteria range from the following selection:

¢ No Criteria Fields
e Serial number

e Software revision

e Hardware revision

Select All Equipment or choose from the Equipment Selection List (refer to
Figure 4-1).

Enter a Range of numbers corresponding to the criteria selection if needed.
Example: Serial numbers from 10700500 to 10700600.

Select OK to run the report (refer to Figure 4-2).

Refer to Table 4-1 for an explanation of each field.
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= Network Hevisions Report

Standard NMM + No Criteria Field &)
ENMM —

20 Timeslot Switch

20 30 Timeslot Switch
850nM 10db Multi Mode
Power Supply

Token Ring MAU

2 Port D51

Figure 4-1. Network Revisions Report Selection

PremNet : MultiRing View
File Edit Yiew Tools

I/ 2 16M Token Ring 16M Mods EDIC1OS
I/ 7 16M Token Ring loM Mods ARRO12

Figure 4-2. Network Revisions Report
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Table 4-1. Network Revision Report Information

Detail Description
Ring Ring of the selected equipment.
Node Node of the selected equipment.
Position Position of the selected equipment in the node.
ID Type of equipment in the specified position.
S/N Serial number of the equipment.
S/IW Software revision of the equipment.
H/W Hardware revision of the equipment.

Nodal Configuration Report

When a node is selected, the Nodal Configuration Report displays the hardware and
software revision levels for all the cards in the node, along with other important
information. This is useful when troubleshooting the network.

Generating a Nodal Configuration Report
1. Select Reports from the Tools menu.

2. Select Nodal from the Reports menu.

Note: A nodal view must be displayed to generate a nodal report.

An example of a Nodal Configuration Report is displayed in Figure 4-3, and the report
information is described in Table 4-2.
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PremMet : Card Yiew
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Figure 4-3. Nodal Configuration Report

Table 4-2. Nodal Configuration Report Information

Detail Description
Position Position of the module.
1D Type of module in the specified position.
Cnfg. Configuration of the node. There are only two options:
e CRR (Counter Rotating Ring) or
¢ REDNT (Redundant)
Status Indicates whether the module is active, on standby, or in alarm status
S/N Serial number of the module.
S/W Software revision of the module.
H/W Hardware revision of the module.
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Cancel Reports

You can prematurely terminate the gathering of information. This feature is also useful
if, for example, the node is not responding or the network is slow to respond.

To cancel a report, select Cancel from the Tools menu.
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