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About This Manual

Manual Description

This User’s Guide is designed to help you understand and operate the Excalibur SNMP
DAP Manager for Windows.  Before you start, it is important that you have a thorough
understanding of your network configuration.  You should also be familiar with the basic
skills and concepts required to use a Microsoft Windows-based application.

This manual is organized as follows:

Chapter 1 – Introduction provides an overview of what you can do with the Excalibur
SNMP DAP Manager.

Chapter 2 – Database Configuration explains how to add your SNMP DAP units to the
CMS 400 or HP OpenView database.

Chapter 3 – Starting SNMP DAP Control explains how to start the application that
provides the primary means of managing your SNMP DAP units.

Chapter 4 – Unit Configuration explains how to configure the parameter settings of
your SNMP DAP units.

Chapter 5 – Monitoring explains how to monitor EIA interface signals, analog signal
levels, line quality statistics, and stored alarms.

Chapter 6 – Unit Control explains how to initialize units, squelch units, send call
messages, and use front panel emulation.

Chapter 7 – Dial Backup explains how to configure phone numbers and initiate dial
backup connections.

Chapter 8 – Testing explains how to perform diagnostic tests on your units.

Chapter 9 – Performing Software Upgrades explains how to download new software
to a 6456 DAP.

Related Documentation
If you are running this application on the CMS 400 network management system, refer to
the following manuals for additional information:

• The CMS 400 Installation Manual (Part No. 13D26A-14) explains how to install
your hardware and software.  It provides a complete description of system
components, cabling requirements, and power connection procedures.
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• The CMS 400 Reference Manual (Part No. 13D26A-10) describes the basic skills
and concepts you'll need to use the CMS 400.

• The CMS 400 User's Guide (Part No. 13D26A-7) explains how to use specific
CMS 400 applications.  The information in this manual is generic to all types of
managed products.

If you are running this application on the HP OpenView management platform, refer to
the following manuals for additional information:

• Racal Device Managers for HP OpenView for Windows Installation Instructions
(Part No. 13D50A-14) explains how to install this application in an HP
OpenView environment.

• HP OpenView for Windows User’s Guide describes the features and functions of
HP OpenView.

Terminology and Conventions

This manual uses the following typographical conventions:

• Text appearing on a computer screen is shown in this font:

Select Configure from the Tools menu.

• Characters that you must type on a keyboard are shown in this font:

In the Diagnostics field, type SNMP.

• Special keys that you must press on a keyboard (such as Enter or Ctrl) are shown
in brackets:

Press [ENTER].
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Chapter 1
Introduction

About the Excalibur SNMP DAP Manager
The Excalibur® SNMP DAP Manager for Windows enables you to manage your entire
network of Excalibur SNMP DAP and Excalibur DAP 6456/SNMP units from a single
PC workstation.  You can configure unit options, monitor operating status, initiate dial
backup, display statistics, receive alarms, and conduct tests — all without the aid of
remote personnel.

Note:  Throughout this manual, the various models of Excalibur SNMP DAP and
Excalibur DAP 6456/SNMP are referred to simply as SNMP DAP, unless the
instructions are pertinent to a specific model.

This Windows-based application provides you with an easy-to-use graphical interface
for managing your SNMP DAPs.  You can quickly select any management function
using pulldown menus or toolbar buttons.  Graphic displays make it easy for you to
analyze management information.  If you need guidance with any procedure, context-
sensitive on-line help is always a mouse click away.

The Excalibur SNMP DAP Manager application can operate on the following network
management platforms:

• Milgo Solutions Communications Management Series (CMS) 400

• Hewlett-Packard HP OpenView for Windows

Management Features
The Excalibur SNMP DAP Manager has an extensive array of features to give you
complete centralized control of your SNMP DAPs:

• Unit Configuration − Use this feature to view and change parameter settings for
any unit in the network.  You can create configuration files that you can download
to one, several, or all units in the network.  You can also compare the
configurations of any two units or configuration files to quickly identify how they
differ.

• Status Monitoring − Use this feature to quickly view the status of any unit in the
network.  You can monitor EIA interface signals, analog signal levels, and stored
alarms.
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• Statistics Monitoring − Use this feature to precisely measure and graphically
display the quality of the digital line.

• Dial Backup − Use this feature to originate and disconnect dial backup
connections for failed leased line circuits.

• Unit Testing − Use this feature to perform comprehensive diagnostic testing on
any network unit.  Graphic displays show functional diagrams of each test being
run.

• Front Panel Emulation − Use this feature to control a DAP as if you were sitting
at its front panel.  You can view a graphic representation of the front panel and
“press” buttons using a mouse or keyboard.

• Software Downloading − Use this feature to upgrade the software in a 6456 DAP
by downloading new image files.
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Chapter 2
Database Configuration

Overview
Before you can manage your SNMP DAPs, you must install the Excalibur SNMP DAP
Manager software option key and connect your SNMP DAP units to the network
management system.  To install the software:

• If you use the CMS 400 platform, refer to the CMS 400 Installation Manual.

• If you use the HP OpenView platform, refer to Racal Device Managers for HP
OpenView for Windows Installation Instructions.

To connect the SNMP DAP to the network management system, refer to your SNMP
DAP’s Installation and Operation Manual for instructions.

Once you’ve installed the software and made the necessary connections, you can then
add the SNMP DAP units to the network management database.  The procedures differ
for CMS 400 and HP OpenView management platforms.

Adding Units - CMS 400
To add SNMP DAP units to the CMS 400 database, you use the Network Map
application.  From the CMS main window, you can start Network Map in two ways:

• Click the  toolbar button.

• Select Database from the Commands menu.  Then select Network Map from the
adjacent menu.

The Network Map screen appears.  To add each SNMP DAP to the CMS 400 database:

Note:  These procedures are specific to SNMP DAP units.  For general information on
creating and modifying a CMS 400 database, see the CMS 400 User’s Guide.

1. Select Insert from the list of options at the bottom of the screen.

The Insert Unit screen appears.  (See Figure 2-1.)
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Figure 2-1.  Insert Unit Screen

2. Define the fields in the Insert Unit screen as follows:

Name − Enter a unique name to identify the unit.

Type − For Excalibur SNMP DAP units, enter Excal DAP / SNMP.
For Excalibur DAP 6456/SNMP units, enter 6456 DAP.

Diagnostics − Enter SNMP.

Channel − Leave blank.

Address − Enter the unit’s IP address.

Set other fields in the screen as desired.

3. Select Accept Input (or press [PGDN]) to add the unit to the database.

Adding Units - HP OpenView
Use the HP OpenView Autodiscovery feature to add SNMP DAP units to the database.
This feature automatically locates the SNMP DAPs in the network and adds them to the
database with the name Excalibur DAP or 6456 DAP.  The devices appear as Excalibur
DAP or 6456 DAP icons in HP OpenView maps.

For complete information about using the Autodiscovery feature, refer to the HP
OpenView for Windows User’s Guide.
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Chapter 3
Starting SNMP DAP Control

Overview
The SNMP DAP Control application is the primary means of managing your Excalibur
SNMP DAP and Excalibur DAP 6456/SNMP units.  You can use this application to
configure, monitor, and test any SNMP DAP in your network.  This chapter explains
how to start the application and perform basic operations.

Starting SNMP DAP Control - CMS 400
To start the SNMP DAP Control application from the CMS 400:

1. From the CMS main window menu bar, select Commands.

2. Select WAN Control from the pulldown menu.

3. Select DAP Control (SNMP) from the adjacent menu.

The Select A Single Unit screen appears.  (See Figure 3-1.)

Figure 3-1.  Select A Single Unit Screen
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4. Select the unit you want to control and click OK.

The SNMP DAP Control main window appears.  (See Figure 3-2.)

Starting SNMP DAP Control - HP Openview
To start the SNMP DAP Control application from HP OpenView:

1. From an HP OpenView map, double-click on the icon of SNMP DAP unit you
want to control.

A popup menu appears.

2. Select View.

The SNMP DAP Control main window appears.  (See Figure 3-2.)

SNMP DAP Control Main Window
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Figure 3-2.  SNMP DAP Control Main Window
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In the SNMP DAP Control main window, a graphic display of the selected unit appears.
The displayed unit can be an Excalibur SNMP DAP (shown above) or an Excalibur DAP
6456/SNMP.  Basic unit information appears above the graphic display of the unit.  The
following icons may appear beneath the unit:

• The Alarm icon ( ) appears if the unit has an active alarm.

• The Test icon ( ) appears if the unit has an active test.

• The  icon appears if communications with the unit are lost.

Use the menu bar to select commands using pulldown menus.  Use the toolbar to select
commands with a single mouse click.  The status bar shows the status of the current
operation.  It also defines the function of the highlighted command or toolbar button.

To bring up a popup menu listing every operation you can perform on the unit, click the
right mouse button anywhere in the application window.  To start an operation from this
menu, click on the desired menu item.

Rotating Unit View
You can rotate the graphic display of the unit from the front panel to the rear.  The rear
view shows the unit’s interface connectors.

You can rotate the view in two ways:

• Click the  button on the toolbar.

• Select Rotate from the View menu.

Figure 3-3 shows the rear view of a multiport model Excalibur SNMP DAP.
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Figure 3-3.  Rear View

Selecting Interfaces from Rear View
When the rear view is displayed, you can select an individual DTE or DDS interface.
You can then start operations on the selected interface.

1. To select an interface, position the cursor on it and click the left mouse button.

The selected interface is highlighted.

2. To display a popup menu of the operations you can perform on the selected
interface, position the cursor on the interface and click the right mouse button.
(See Figure 3-4.)

3. To start an operation from this menu, click on the desired menu item.
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Figure 3-4.  Starting Operation on Selected Interface

Viewing Unit Details
Use the Details feature to view information about the unit or a specific interface.  The
information displayed depends on whether an interface is selected from the rear view:

• If you start this feature while an interface is not selected, general information
about the unit appears.  This information includes the node description, contact,
name, location, unit software revision, serial number, and part number.

• If you start this feature while an interface is selected, detailed configuration
information about the specific interface is displayed.

You can start the Details feature in the following ways:

• Click the  button on the toolbar.

• Select Details from the View menu.

• Select an interface from the rear view, bring up its popup menu, and then select
Details.  (See previous section for instructions.)



Excalibur SNMP DAP Manager for Windows User’s Guide

3-6

Pinging the Unit
Use the Ping feature to verify that the selected unit is communicating with the
management system.  The system sends the unit an ICMP ping packet.  The screen
displays whether the unit responded.

You can ping the unit in two ways:

• Click the  button on the toolbar.

• Select Ping from the Tools menu.

Controlling Unit through Direct SNMP
The SNMP DAP Control application provides an easy-to-use graphical interface for
configuring, monitoring, and testing your SNMP DAP units.  You can also control the
SNMP DAP MIB variables directly using the generic SNMP control application
provided with CMS 400 or HP OpenView.

Note:  For information about the CMS 400 SNMP Control application, refer to the CMS
400 LAN Internetworking Manager User’s Guide.  For information about the HP
OpenView SNMP Manager function, refer to the HP OpenView User’s Guide.

You can start the generic SNMP application from the SNMP DAP Control main window
in two ways:

• Click the  button on the toolbar.

• Select Direct SNMP from the Tools menu.

Controlling Unit through Telnet
From the SNMP DAP Control application, you can launch a user-supplied Telnet
application or the CMS 400 Telnet Terminal application (if using CMS 400).  A Telnet
application lets you control units that support the Telnet protocol through a VT-type
terminal emulator.  To specify which Telnet application you want to use:

1. Select Telnet from the Options menu.

The Telnet Options dialog box appears.
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2. To select the CMS 400 Telnet Terminal application, click on Global Telnet for
Racal Management.

To select a user-supplied Telnet application, click on Local Telnet.  Then enter
the path to that application.  For example: C:\PCTCP\TN3270\TN3270.EXE.

3. Click OK.

To launch the selected Telnet application, do one of the following:

• Click the  button on the toolbar.

• Select Telnet from the Tools menu.
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Chapter 4
Unit Configuration

Overview
The Excalibur SNMP DAP Manager enables you to configure the parameter settings of
an entire network of SNMP DAPs from a central location.  This chapter explains how to:

• Start the Configure DAP application.

• Create and modify configuration files.

• Send configuration files to units.

• Configure units directly (without using configuration files).

• Compare two sets of parameter configurations.

• View a list of all parameters for a unit.

Refer to the appropriate SNMP DAP manual for detailed descriptions of the different
parameters you can set.

Starting SNMP DAP Configuration Application
Use the Configure DAP application to quickly configure the SNMP DAPs in your
network.  You can start this application from the SNMP DAP Control main window in
the following ways:

• Click the  toolbar icon.

• Select Configure from the Tools menu.

• Select an interface from the rear view, bring up its popup menu, and then
select Configure.  (See “Selecting Interfaces from Rear View” in Chapter 3
for more information.)

The Select a Target screen appears.  (See Figure 4-1.)
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Figure 4-1.  Select a Target Screen

From this screen, you can select one of the following target types:

• Unit – Select to configure an SNMP DAP unit directly.

• File – Select to open an existing configuration file.

• New – Select to create a new configuration file.

The following sections explain how to perform each of these procedures.

Creating Configuration Files
A configuration file defines a particular configuration of unit parameter settings.  You
should create one configuration file for every unit or group of units in your network that
you want to configure identically.  Once you create a configuration file, you can then
send it to all of the units you want to configure identically.

To create a configuration file:

1. From the Select a Target screen (Figure 4-1), select New and then click the Next
button.

2. Select the type of unit you want to create a configuration file for:  SNMP DAP
or 6456 DAP.  Then click the Next button.
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If you are creating a configuration file for an SNMP DAP, follow step 3.  If you are
creating a configuration file for a 6456 DAP, skip to step 4.

3. The Configure DAP Dependencies screen appears.  (See Figure 4-2.)  This
screen enables you to define configuration dependencies for the SNMP DAP(s)
you are creating the file for.  These dependencies determine the parameters that
you will be able to configure for the file.  For example, if you select a multiport
unit (Number of Ports = 6), you will only be able to configure parameters that
pertain to multiport units — other parameters will appear grayed out.

Set each dependency to the desired setting and then click Done.

Figure 4-2.  Dependencies Screen

4. The Configure DAP main screen appears.  (See Figure 4-3.)  Select the section
of parameters you want to configure and click Next.
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Figure 4-3.  Configure DAP Main Screen

5. Set the parameters in the selected section to the desired values and click the
Done button.

The main screen reappears.

Repeat steps 4 and 5 for each section of parameters you want to configure.

6. Click the Save As button.

The Save As Unit/File screen appears.

7. Select File and then click the Select button.

8. Enter the desired filename and then click the Save button.

The main screen reappears with the name of the new file in the heading.

Opening Existing Configuration Files
To open an existing configuration file, follow these steps from the Select a Target screen
(Figure 4-1):

1. Select File and then click the Select button.
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2. Select the desired file and click Open.

The Select a Target screen reappears with the filename displayed.

3. Click Next.

If you are opening an SNMP DAP configuration file, the selected configuration
dependencies for the file appear.  Proceed to step 4.

If you are opening a 6456 DAP configuration file, the Configure DAP main
screen appears with the filename in the heading.

4. Click Done.

The Configure DAP main screen appears with the filename in the heading.

Modifying Existing Configuration Files
To make changes to an existing configuration file:

1.  Open the file as described in the previous section.

2. Make desired changes as described in steps 4 and 5 of “Creating Configuration
Files.”

3. Click the Save button.

Sending Configuration Files to Units
After you create a configuration file, you can then send it to the desired unit(s).  You can
send the same file to any number of units you want to configure identically.

Follow these steps to send a configuration file to a unit:

1. Open the file you want to send.  (See “Opening Existing Configuration Files.”)

The Configure DAP main screen appears with the filename in the heading.

2. Click the Save As button.

The Save As Unit/File screen appears.

3. Select Unit and then click the Select button.

4. Select the desired unit and then click OK.

The configuration file is sent to the selected unit.
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Configuring Units Directly
To configure a unit’s parameter settings directly (without using configuration files),
follow these steps:

1. From the Select a Target screen (Figure 4-1), select Unit and then click the
Select button.

2. Select the unit you want to configure from the displayed list.  Then click OK.

A dialog box appears prompting you to select the method of communicating
with the unit.

3. Select Directly through SNMP and click OK.

The Select a Target screen reappears with the selected unit name displayed.

4. Click Next.

If you are configuring an SNMP DAP, the Configure DAP Dependencies screen
appears.  Proceed to step 5.

If you are configuring a 6456 DAP, the Configure DAP main screen (Figure 4-3)
appears with the unit name in the heading.  Proceed to step 7.

5. Click Done.

The Results screen appears.

6. Click Close.

The Configure DAP main screen (Figure 4-3) appears with the unit name in the
heading.

7. Select the section of parameters you want to configure and click Next.

8. Set the parameters in the selected section to the desired values and click Done.

The Results screen appears, showing the progress of the parameter change(s)
being sent to the unit.

9. When the Results screen displays Completed, click Close.

The main screen reappears.

Repeat steps 7 to 9 for each section of parameters you want to configure.
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Comparing Configurations
The Configure DAP application allows you to compare the parameter settings of one unit
or configuration file with those of another unit or configuration file.  This feature lets
you quickly identify the differences between two sets of configurations.

1. If the first configuration you want to compare is that of a  configuration file,
open the file (see “Opening Existing Configuration Files”).

If the first configuration you want to compare is that of a unit, select the unit
(follow steps 1 to 6 in “Configuring Units Directly”).

2. From the main screen, click Compare Unit or Compare File.

3. Specify the unit or file containing the second configuration you want to
compare.  Then click OK.

4. Click View to compare the settings of the two configurations.  The parameter
settings of the second configuration are shown in brackets beneath the settings of
the first configuration.

Viewing Parameter List
To view a listing of all parameters available for the selected unit or file, click the View
button in the main screen.  The highlighted configuration section is displayed first.  You
can print the list or copy it to the Windows clipboard.
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Chapter 5
Monitoring

Overview
The Excalibur SNMP DAP Manager provides extensive monitoring capabilities to help
you verify network operation and detect problems.  This chapter explains how to:

• Monitor EIA signal status

• Monitor analog signal levels

• Monitor line quality statistics

• Monitor stored alarms

Monitoring EIA Signal Status
Use the Monitor EIA application to monitor the EIA signal status of your SNMP DAPs.
This application displays the status of 14 different EIA interface signals plus the unit’s
operating speed.  Monitoring a unit’s EIA signal status can help you detect problems and
troubleshoot your system.

To start the Monitor EIA application from the SNMP DAP Control main screen, do one
of the following:

• Click the  toolbar button.

• Select Monitor EIA from the Tools menu.

• Select a DTE port from the rear view, bring up its popup menu, and then select
Monitor EIA.  (See “Selecting an Interface from Rear View” in Chapter 3 for more
information.)

The Monitor EIA screen shows a continuously updated, scrolling display of EIA signal
statuses for the selected unit(s).  The type of screen shown depends on the setting of the
Graphical option in the View menu:

• If the Graphical option is enabled, the status of each signal is indicated by a
colored box.  (See Figure 5-1.)  The bottom of the screen provides a color legend.

• If the Graphical option is disabled, the screen displays the signal status with text
characters:  T = true or on, • = false or off, and * = in transition.
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Figure 5-1.  Monitor EIA Screen – Graphic View

Switching Graphic/Text View

The Monitor EIA application allows you to customize the way the screen displays the
EIA signal status.  When you first run this application, the screen displays the graphic
view (color boxes).  If you want to display text characters instead:

• Click the  toolbar button or select Graphical from the View menu.

Switching Unit Name/Address Display

The Monitor EIA application allows you to customize the way the screen identifies the
unit being monitored.  When you first run the application, the screen displays the unit
name.  If you want to display the unit address instead:

• Click the  toolbar icon or select Unit Name from the View menu.

Pausing the Display

To pause the scrolling display (or restart a paused display):

• Click the  toolbar button or select Pause from the View menu.
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Monitoring Analog Levels
Use the Monitor Analog application to monitor the analog signal levels of SNMP DAPs.
This application gives you real-time measurements that are continuously updated.

Note:  Excalibur SNMP DAPs and 6456 DAPs allow monitoring of receive level,
transmit level, and signal quality.  Excalibur SNMP SET-1 DAPs only allow monitoring
of signal quality.

To start the Monitor Analog application from the SNMP DAP Control main screen, do
one of the following:

• Click the  toolbar button.

• Select Monitor Analog from the Tools menu.

• Select the DDS port from the rear view, bring up its popup menu, and then select
Monitor Analog.  (See “Selecting an Interface from Rear View” in Chapter 3 for
more information.)

The Monitor Analog screen shows the current values for a variety of analog signal
levels.  The type of screen shown depends on the setting of the Graphical option in the
View menu:

• If the Graphical option is enabled, the graphic display appears.  (See Figure 5-2.)
A horizontal bar indicates the current level, which is updated every few seconds.
If the analog level is within the user-defined acceptable range, the bar will be
green.  If it is outside the acceptable range, the bar will be red.

• If the Graphical option is disabled, the screen shows the analog levels in text
characters.  (See Figure 5-3.)  Values marked with a ? are taken from the previous
poll of the unit; the most recent poll could not determine a new value.  Values
marked with a > are approximate.
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Figure 5-2.  Monitor Analog Screen – Graphic View

M onito r A nalog  Param eters

Figure 5-3.  Monitor Analog Screen – Text View

You can switch between unit name/address and graphic/text view in the same manner
described in the “Monitoring EIA Signal Status” section.
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Monitoring Statistics
SNMP DAPs have a Line Quality Statistics (LQS) feature that allows you to precisely
measure and graphically display the quality of the digital line.  This feature provides
information about the percentage of time the line is available for use and allows you to
identify specific digital line problems.  For information on the different statistics you can
monitor, see the appropriate SNMP DAP manual.

To start the Statistics application from the SNMP DAP Control main screen, do one of
the following:

• Click the  toolbar button.

• Select Statistics from the Tools menu.

• Select the DDS interface from the rear view, bring up its popup menu, and then
select Statistics.

The Request Statistics screen appears.

Defining Statistics Interval

The SNMP DAPs can store up to 24 intervals of line statistics.  You can set the statistics
gathering interval from 1 minute to 99 days.  The default interval is 1 hour.

To define the statistics gathering interval, follow these steps starting from the Request
Statistics screen:

1. Click the  toolbar button or select Set Parameters from the Tools menu.

2. Specify one or more DAPs and click OK.

A screen showing the unit’s current statistics interval appears.

3. Enter the desired interval and click OK.

Note:  Changing the statistics interval clears all stored statistics and starts a new interval.

Retrieving Statistics from Unit

To retrieve and display an SNMP DAP’s stored line quality statistics:

1. Click the  toolbar button or select Fetch Statistics from Unit from the Tools
menu.

2. Specify the unit and click OK.
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• If the Graphical option in the View menu is enabled, a graphic bar chart of
the unit’s statistics appears.  (See Figure 5-4.)  The green area to the left of
each bar indicates the user-defined acceptable range for the statistics.  The
blue area indicates the unacceptable range.  The column labeled A represents
the average value of all intervals.  The column labeled C represents the
current incomplete interval.

• If the Graphical option is disabled, a text display of the statistics appears.
(See Figure 5-5.)
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ra ng e ; b lu e
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ra n g e

A v e ra ge  in te rva l
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a va ila b le  s ta tis t ic s C u rren t ly  s e le c te d
in te rva l len g th

2 4  m o st
re c e n t
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R e quest S ta tis tic s

Figure 5-4.  Statistics Display – Graphic View
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Figure 5-5.  Statistics Display – Text View

While viewing the statistics, you have the following options:

To switch between graphic and text view

• Click the  toolbar button or select Graphical from the View menu.

To switch between seconds of unavailability and percentage available

You can customize the display to show seconds of unavailability or percentage of
availability for each statistic.

• Click the  toolbar button or select Seconds of Unavailability from the View
menu.

To view different statistics

The graphic view shows only one type of statistics at a time.  The text view shows the
counter statistics separately from the seconds of unavailability/percentage of availability
statistics.  To view other statistics:

1. Click the down arrow at the bottom of the screen.

A list of available statistics appears.
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2. Click the type of statistics you want to view.

To change the acceptable range thresholds

You can customize the thresholds that define the acceptable range display on the graphic
view.  You can set the percentage threshold from 0 to 100 and the error count threshold
from 0 to 300.  You can also enable or disable the thresholds display.

1. Select Thresholds from the Options menu.

2. Enter desired thresholds and click OK.

Storing Statistics to File

The Request Statistics application allows you to add the statistics you retrieved to the
system’s statistics file.  You can then view the stored statistics at a later date to analyze
your digital line quality.

• Click the  toolbar button or select Store Results to File from the Tools menu.

Displaying Stored Statistics

To display the statistics stored in the statistics file:

1. Click the  toolbar button or select Fetch Results From File from the Tools
menu.

A screen appears showing the record number, date, and time of each statistics
entry stored in the file.

2. Select the entry you want to display.

If desired, click Filter to specify criteria for the entries you want to see.  You can
specify a starting number, date and/or time range, or a specific unit.

3. Click OK.

The screen displays the statistics.  You can now view these statistics in the same
manner described in “Retrieving Statistics from Unit.”
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Deleting Statistics File

To delete the statistics file, click the  toolbar button or select Delete Result File from
the Tools menu.  A warning appears alerting you that all statistics entries will be deleted.
If you are certain you want to delete the file, click Yes.

Resetting Unit Statistics

To reset a unit’s stored statistics:

1. Click the  toolbar button or select Reset Statistics from the Tools menu.

2. Specify the unit(s) you want to reset and click OK.

The selected unit then starts a new statistics interval.

Monitoring Stored Alarms
The SNMP DAPs alert you to irregular conditions by issuing alarms.  The SNMP DAP
Control application displays a bell icon when an alarm occurs.  It then stores the alarm in
an alarm queue, with the most recent one last.

To view the alarms in the alarm queue that pertain to the selected unit, do one of the
following from the SNMP DAP Control main window:

• Click the  toolbar button.

• Select Alarms from the Tools menu.
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Chapter 6
Unit Control

Overview
This chapter explains how to control the operation of your Excalibur SNMP DAPs.  It
explains how to:

• Initialize units

• Squelch units

• Send call messages to units

• Control units using front panel emulation

Note:  The features described in this chapter are not available for 6456 DAPs.

Initializing Units
The SNMP DAP Control application allows you to perform a hardware reinitialization
on a unit.  This disconnects active dial backup connections and ends any tests in
progress.  Squelched units are again allowed to transmit normally.  Unit option settings
remain unchanged.

To initialize the currently selected unit:

1. Select Control Unit from the Tools menu.

2. Select Initialize Unit from the adjacent menu.

The screen displays a message to inform you that the unit has been successfully
initialized.

Squelching Units
The SNMP DAP Control application allows you to squelch a unit, preventing it from
transmitting.  This feature is useful for multidrop applications in which you suspect that
a remote unit is streaming, preventing other drops from transmitting.

To squelch the currently selected unit:

1. Select Control Unit from the Tools menu.
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2. Select Squelch Unit from the adjacent menu.

The screen displays a message to inform you that the unit has been successfully
squelched.

To return a squelched unit to a normal operating state, refer to “Returning Units to
Normal.”

Returning Units to Normal
The Return to Normal feature allows you to return a unit to a normal operating state.
Tests are ended, alarms are reset, and squelched units are again allowed to transmit.
This feature does not affect the dial status of a unit.

To return the currently selected unit to normal:

1. Select Control Unit from the Tools menu.

2. Select RTN from the adjacent menu.

The screen displays a message to inform you that the unit has been successfully
returned to normal.

Sending Call Messages
The Call feature allows you to send coded messages to Excalibur SNMP DAPs in the
network.  To send a message, you must first enter one of 10 numerical codes (0-9).  Each
code signifies a previously agreed upon message.  For example, 5 can indicate that the
system is going down in 5 minutes.  After you enter the code, you can then send it to the
selected unit, where it appears on the front panel screen.  This feature allows you to
communicate with remote personnel without making costly telephone calls.

To send a call message:

1. Select Call Message Default from the Options menu.

2. Enter the code number (0-9) and click OK.

3. Select Control Unit from the Tools menu.

4. Select Call Unit from the adjacent menu.

The message is then sent to the selected unit.
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Using Front Panel Emulation
Use the Front Panel Emulation feature to control an Excalibur SNMP DAP as if you
were sitting at its front panel.  The screen shows you a graphic display of the unit’s front
panel.  You can “press” buttons using the mouse.  You can view the front panel screen as
it changes to a new display.

You can start Front Panel Emulation in two ways:

• Click the  button on the toolbar.

• Select Control Unit from the Tools menu.  Then select Front Panel from the
adjacent menu.

A graphic display of the selected unit’s front panel appears.  (See Figure 6-1.)

Click to
press button

Excalibur Fron t Panel

Figure 6-1.  Front Panel Emulation Screen

Controlling Front Panel

You can "press" a front panel button in three ways:

• Click on the desired button in the front panel graphic representation.

• Click on the toolbar button representing the desired front panel button.

• Select the desired button from the Tools menu.
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To increase the size of the front panel display, click on the blue LCD screen or select
Zoom from the View menu.

Changing Polling Rate

The polling rate is the rate (in seconds) at which the management system automatically
polls the unit for its current display data.  The default rate is 10 seconds.

To change the polling rate or turn off unit polling completely:

1. Select Polling from the Options menu.

2. Enter the desired polling rate.  To enable/disable polling, click the Auto-Polling
Enabled box.  Then click OK.

To instantly poll the unit for its current display, click the  toolbar button or select
Refresh from the View menu.
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Chapter 7
Dial Backup

Overview
Dial backup restores communications when a dedicated line fails.  The Excalibur SNMP
DAP Manager allows you to control dial backup operations for an entire network of
Excalibur SNMP DAPs from a central location.  This chapter explains how to:

• Start the Excalibur Dial Backup application.

• Initiate dial backup connections.

• End dial backup connections.

• Test dial line operation.

• Configure a unit’s stored phone numbers.

Note:  Dial backup is not available for 6456 DAPs.

Starting Excalibur Dial Backup Application
Use the Excalibur Dial Backup application to control dial backup operation for Excalibur
SNMP DAPs equipped with the Integral Dial Backup (IDBU) option.  To start this
application from the SNMP DAP Control main screen:

1. Select Control Unit from the Tools menu.

2. Select Restoral from the adjacent menu.

The Excalibur Dial Backup screen appears.  (See Figure 7-1.)
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Figure 7-1.  Excalibur Dial Backup Screen

Initiating Dial Backup Connections
To establish a dial backup connection:

1. Click the  toolbar button or select Initiate Dial Backup from the Tools menu.

The Initiate Dial Backup screen appears.  (See Figure 7-2.)
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Figure 7-2.  Initiate Dial Backup Screen

2. If you want the selected unit to dial a phone number other than its stored Target
number, enter the number in the Telephone Number field.  (See “Configuring
Phone Numbers” for information about changing the unit’s stored phone
numbers.)

3. If desired, you can select the following options:  Number of Dial Retries and
Switch to Dial on Connect.

4. Click OK.

The system commands the unit to place the dial backup call.  The status area of
the screen updates you on call progress.

If you enabled the Switch to Dial on Connect option, the unit switches communication
from the dedicated to the dial backup lines when the connection is established.  If you
did not enable this option, select Switch to Dial Lines from the Tools menu when you
want to move data to the dial backup lines.

Ending Dial Backup
During dial backup operation, you may want to verify dedicated line operation without
disconnecting the dial backup connection.  To do so, select Switch to Dedicated Lines
from the Tools menu.  The unit then switches communication to the dedicated lines
while retaining the dial backup connection.
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When you are satisfied the dedicated lines are operating properly, select Terminate Dial
Backup from the Tools menu.  The unit disconnects the dial line and returns
communication to the dedicated lines.

Testing Dial Lines
The Excalibur Dial Backup application allows you to run two tests to verify that the dial
lines are operating properly.  You can select the following tests from the toolbar or the
Tools menu:

Verify Dial Line Presence – Commands the unit to take the dial lines off-hook
and check for a dial tone.  This test can be run only during dedicated line
operation.

Call Self-Test – Commands the unit to establish a dial line connection between
its transmit and receive lines.  The unit then transmits a handshake message to
verify the connection is functioning properly.  This test can be run only during
dedicated line operation.

Note:  If the selected unit does not support a particular test, the test name will appear in
light gray, indicating you cannot select it.

Configuring Phone Numbers
You can use this application to configure the selected unit’s stored phone numbers.  To
do so, click the  toolbar button or select Configure Phone Numbers from the Tools
menu.  See the appropriate Excalibur SNMP DAP manual for information about the
different phone numbers you can store.
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Chapter 8
Testing

Overview
The Excalibur SNMP DAP Manager lets you perform a full range of diagnostic tests on
the Excalibur SNMP DAPs in your network.  This allows you to quickly isolate and
solve network problems without any aid from remote personnel.

Starting Test Unit Application
To start the Test Unit application from the SNMP DAP Control main screen, do one of
the following:

• Click the  toolbar button.

• Select Test from the Tools menu.

• Select an interface from the rear view, bring up its popup menu, and then select
Test.

Note:  The Test Unit application is not available for 6456 DAPs.

The Test Unit screen appears.  (See Figure 8-1.)
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Figure 8-1.  Test Unit Screen

Available Tests
The Test Unit application allows you to run the following tests:

Analog Loop Unit – Loops the unit’s analog interface back to the unit.  You
must use external test equipment if you want to generate a test pattern through
the looped path.

Digital Loop Unit – Loops the unit’s digital interface back to the DTE.  You
must use external test equipment if you want to generate a test pattern through
the looped path.

Self-Error Test – Loops the unit’s transmitter to its receiver and generates a test
pattern through the looped path.  The unit’s test pattern comparator checks the
received pattern for errors.

Digital Loop Test – Requires two units.  Loops the far-end unit’s digital
interface back toward the highlighted unit.  The highlighted unit generates a test
pattern through the looped path and checks the received pattern for errors.

End-to-End Error Test – Requires two units.  During this test, both units send
a test pattern across the DDS lines.  The test pattern comparators at each unit
check the received pattern for errors.
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Note:  For detailed descriptions of the tests and testing strategy, refer to the appropriate
Excalibur SNMP DAP manual.

Caution:  Certain tests interrupt network management communications.  If you start one
of these tests, you may lose communications with the unit, depending on which port is
providing the diagnostic signal.  Refer to the unit’s manual for detailed information on
the signal paths created by the different tests.

Selecting Partner Unit
The Test Unit application allows you to select a partner unit for tests that require two
units.

1. Select Partner Unit from the Options menu.

2. Specify the desired unit and click OK.

Starting Tests
To start a test:

1. Click the  toolbar icon or select Initiate Test from the Tools menu.

A dialog box appears, allowing you to specify the type of test you want to run.
(See Figure 8-2.)

Figure 8-2.  Test Selection Screen

2. Select the test you want to run.
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• For tests with test patterns, you can specify the test duration (if you want to
change the default setting).

• For tests with multiport units, you can specify an individual port to run the
test through.  (This option is not supported on all units.)

3. Click OK.

The screen displays a functional diagram of the selected test.  An error counter
appears for tests with test pattern generation.  The status bar displays the name
of the test being run and its current status.

Ending Tests
Tests with test pattern generation end when the timer expires.  If you selected a test
without test pattern generation, you must end it manually.  You can do so in the
following ways:

• Click the  toolbar button.

• Select Cancel from the Tools menu.

• Close the Test Unit application.
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Chapter 9
Performing Software Upgrades

Overview
This chapter explains how to upgrade the software in a 6456 DAP by downloading new
image files via TFTP.  It also explains how to view the part number and revision number
of image files.

Downloading Software
To download new software to a 6456 DAP, follow these steps from the SNMP DAP
Control main screen:

1. Select Download Software from the Tools menu.

2. Select the image file you want to download and click the Download button.

The file is then sent via TFTP to the unit.

Examining Image Files
To view the part number and revision number of image files, follow these steps:

1. Select Examine Image Files from the Tools menu.

2. Select the image file(s) you want to examine and click the Examine button.

The screen shows the part number and revision number of the selected file(s).
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